• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


All Activity

This stream auto-updates     

  1. Past hour
  2. Well spotted! That's almost through to the carcass. £500 fine right there
  3. Tyre Management System

    Hi, I have just purchased a Ford Focus having driven a Vauxhall Astra for the past 6 years. One of the things the Vauxhall Astra had within the Tyre Management System was the facility to show you the actual tyre pressures of each tyre. I'm not sure if this facility is available within the Ford Focus Tyre Management System? Mark P.
  4. Water leak

    Hi there, I'm new to the forum. My Focus 2006 1.6 tdci has developed a water leak. I top the bottle up to the full mark, drive about sixty miles and the water level is near the bottom of the fill bottle. Checked for visible leaks, can't see any. However after leaving the vehicle overnight and the car is stone cold, when I remove the coolant filler cap the bottle is still pressurized and the water level comes back up the bottle an inch or two? I don't think it can be a leak in the water system or water pump etc as this would lose all pressure overnight I'm thinking. I'm suspecting the head gasket in some way but struggling to understand how it's retaining pressure for so many hours? I recently had a couple of the copper washers on the injectors changed due to blow by and the mechanic told me he had a mother trying to remove number two injector. I'm wondering if he has in some way damaged or cracked the head? The water leak arrived immediately after the injector repair. Your help would be much appreciated by a retired old timer who will attempt his own repairs.
  5. My Mk7.5 Zetec S

    No problem at all bud. I just sent back all the exterior lights to ceuk for a refund. Been nothing but an ***** ache dealing with them. I have my views on why their bulbs are so bad. My LED side lights are now blinking too and look like they have gone "rusty"! So they will be going in the bin. Absolute joke! I'm going to go back to looking at auto beam stuff now.
  6. michaelfastcar

    hi i am a new member i live in walsall west midlands could someone tell where there is meet up,s for escort,s near to where i live thanks for your help
  7. Focus 07 Wiring Loom

    UPDATE . So I changed the three spark plugs no change , changed the coil everything running normal .. for now. I dont want to touch anything else just yet
  8. Today
  9. Electric Wing Mirror Problem

    i had this problem on passenger side on mk6.5 fiesta. i just unplugged the connector so it did not fold in. My worry was that the cogs etc would break and leave it stuck in. so i would prefer it just to stay out. unplugging it also meant no adjustment or heat. This was some years ago, I did try to find out at that time which colour wire did the motor power but could not find it out. I would have just cut the motor wire if i had found out which. Perhaps someone knows which wire as they have been around longer now and more people would have had this problem
  10. whilst not a helpful comment in the circumstances, looks like the tyre has some adverse inner edge wear
  11. Engine service diy 😬

    I always err on the side of caution when someone mentions wanting an oil change done with an oil flush additive. I think for some they have seen it in Halfords or heard of it and think it must be great stuff. My personal opinion is, on a well serviced vehicle using quality modern oil, I don’t see a need for it. on some vehicles with a wet belt it’s a big no no to add flushing additives.
  12. Engine service diy 😬

    That’s brilliant, thank you wilto 👍 will definitely purchase a Haynes manual dee_82 strange that with all the technology a book is the best source of info.. Thanks for all your help will have a go and report back
  13. Reverse camera fitted,cheap ones work fine.

    I installed a camera on my fiesta. Camera was just around £8 and the image isn't bad.
  14. Ford Focus 2007 MK2 Estate 1.8 diesel Just popping round the corner and felt as if I had picked up an empty box under the car, grinding noise etc, stopped and nothing. Turned round and drove home slowly – 1st and 2nd noise continued, not tried other gears. Have jacked up each wheel, all spin by hand no noticeable problems. Finding when in reverse there are no problems and all normal, no grinding, clutch and brakes all as normal. Shift to 1st or 2nd gear pull away and clutch feel strange and a small thump as it comes in, as the car moves the crunching grinding starts, depress clutch and the car will roll with no noise. I am thinking if it’s clutch/flywheel and/or gearbox related then not worth the expense. I am thinking perhaps I am missing something, bearing/driveshaft’s. I would like to know exactly what the problem is without spending to much, good chance the car is scrap but………… Is this a familiar scenario, should I be looking or trying something ?
  15. My Mk7.5 Zetec S

    Thank you dude! Thank you for the advice, I have been hearing bad things about CEUK more and more on Fiesta Facebook pages; so I think I will go for some Auto-beam headlights - really want to get some white ones in, the dull yellow tinge is really getting to me haha! :) Sorry for the slow reply, haven't been on this in a while
  16. I thought i would share this as most cheap stuff are terrible but this kit is A1,if i want monitor on i press the red socket top if not no power at all. Camera only works in Reverse and if not no power in the wires as i wanted it as then it saves battery.
  17. HID Upgrade on my Mk7. Fiesta Titanium

    Hi, Thanks for getting back to me. I changed out the whole kit including the ballasts, the bulbs come on and the N/S stays on perfect, but the O/S only stays on for about 20 S seconds then goes off. I have had the old set tested and it works fine as does the replacement kit. The strange thing is that the old kit was working fine for months, so I was wondering if there might be a problem with a relay?? as it starts up ok but then fails, theN/S remains on. I have replaced the fuses so I have run out of ideas.
  18. MK3 Focus - What not to do with FoCCCus...

    I had the same issue myself with a loose usb port on an old laptop lol its very scary Jamie
  19. HID Upgrade on my Mk7. Fiesta Titanium

    Did you change the ballast when the got the new bulbs?
  20. nice snow pic

  21. nice snow pic

    Yesterday while I was out delivering it got pretty bad further on
  22. Hi, First time in this forum So here's the issue: Ever since updating to IOS11 on my iPhone, the bluetooth between the phone and my fiesta's stereo is absolutely horrendous! It pops and crackles like a vinyl record, its like having a ***** bowl of Rice Crispies in the back! Both with music and phonecalls. It's driving me up the wall, so I called Apple (who blame Ford,), called Ford (who blames Apple). It's the same for my friend who owns a similar year Fiesta and a new iPhone. So my advice is do not update your phone, or do not buy a '10 model fiesta.
  23. nice snow pic

    My neighbours have been busy...
  24. Control arm bent, drop link snapped...as Stoney says, needs to get in the air and have a full check over, though with luck nothing else will be mullered.
  25. Keyless start

    Christ, didn't they un-pair the missing key before flashing a new one? That could potentially have left a live and functioning key at large.
  26. Hi Folks, I fitted an upgrade kit and all was great for months then all of a sudden the O/S light went off. I thought it was the bulb but I could not get a replacement locally so I bought another kit. After fitting it the lights started working and I thought great, but half a minute later it went out again????? if I switch the lights off for 5 minutes they start up again but the O/S fails again shortly after.Can anybody give me some ideas as to what’s causing this issue.
  27. SYNC 1.1 APIM module configuration

    At this time I do not have the SYNC 1.1 APIM configuration of the 10 speaker Sony audio system. To retrieve the correct configuration I need a license plate number or VIN number of a Focus MK3 with a SYNC 1.1 based 10 speaker Sony audio system. Unfortunately these are very hard to find.
  1. Load more activity