• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


All Activity

This stream auto-updates     

  1. Past hour
  2. Trying to fault my sons 2008 plate Mk6 1.25 Fiesta from 200 miles away. The heater when switched on blows hot air only irrelevant to what blower or heat setting you are on. Switching on the A/C makes no difference whatsoever. Seems to me that no outside/cold air is being allowed into the system. Any ideas please?
  3. 2013 1.0l Ecoboost engine rust. Problem?

    Just read this thread, and I've checked my 2014 Fiesta Ecoboost 100ps! PHEW!!! The pipes on my car are clean, no rust, but I will look in Halfords next time for some high temperature paint. Many thanks for the heads-up, and good luck to those dealing with Fords customer department.
  4. ThaiFiesta's Mk7.5 Fiesta Ecoboost

    ST wheel with cruise control installed today. Removing the airbag is a PITA. Also spruced up my intercooler. Blue Mountune logo to match my theme, some foam strips to help force the air through rather than around, and reinstalled the intercooler fan as static temps were very high.
  5. Hello all

    Hi Welcome
  6. Today
  7. Hello all

    Hi everyone, Just bought a new (2015) Fiesta and thought it would be a good idea to come to the owners club and introduce myself
  8. Ford Fiesta Mk7.5 Rear Diffuser Upgrade (ST)

    i don't seem to have the 2x 6mm bolts for the ST diffuser tabs to do up, where can i get them?
  9. Afternoon all, Bit of a long and conviluded story here but please bear with me because I'm just smashing my head off the wall try to find out what the problem is; and I'm just terrified to take to the only Ford Garage within short driving range (and it's Arnold Clark - oh dear) for them to smack me with a massive bill. I've come home after 3 and a half months at sea and I've started the car up and left her for 30 minutes to get everything all lubed up again - the grandfather had been turning it over but not running it during my stint away - and summarily set off on a wee jaunt. Got to the bottom of the hill of my street (0.5 miles away) and then everything started going off it's head. My radio turned on and off, the dash started flashing like a christmas tree on smack and then my Power Steering and ABS shut down completely. I got the car parked up and then turned her off. Tried to turn her back on again and *click, click, click* the battery was dead. I assumed it was a dud battery as I'd been away for so long so I went and got a brand new one from halfords - installed it, the car started and away I went again. The next day - same story, got her started, running and got her a mile down the road and boom, same problem. But this time with a rather prominent electric-burning smell. Car shut down on her own this time and hasnt started since. She's now been sitting for a week seeing as Im running through a college course and havent had the time to work on her but, my question is: what could this be? I thought maybe the Alternator? But the father in law (mechanic- - 20 years+) has said it could be the PS Pump (but this model has EPS and doesn't need one of those surely?) or just a bad grounding wire. Does anyone on here have a better idea of what this could be? Cheers :)
  10. Dtc D900 & failure to start

    That's more like it
  11. Tool boxes

    Or Machine Mart
  12. Dtc D900 & failure to start

    Picked up a Bosch S4
  13. Fiesta EMLconfig throttle map

    Hmm, it's just rather frustrating that the throttle behaves quite reasonably when stationary, and then goes dead when moving - it really does feel like the computer has thrown a switch. As for limiting torque, we're talking about a 1.4 here! It's not going to be breaking anything! I can believe that's it's for driveability. Although they clearly anticipate it's going to be driven by some moron with the hand-eye coordination of a confused goldfish wearing massive shoes. All my cars have cable throttles, and switching to drive-by-wire is always maddening. Funnily enough, heel n' toe isn't that big an issue - you just adapt to pressing and holding down the throttle before you go for the clutch to change gear, by the time the next gear is in, the engine will have responded. A bigger issue is trying to balance the car through a bend, or pull away smartly from a junction into a gap in traffic. I did wonder if a remap might be the only answer - not really worth it on this old thing. On James Simpson's website, he does mention switching a 'Ford Eco mode' via ELMconfig https://www.jamessimpson.co.uk/elmconfig-enable-ford-ecu-functions/ So I thought there might a similar switch for the TDCi lame-mode. I might have to just send him an e-mail and ask.
  14. Interior Rear Light - Help please

    Hi lew man, okay will give a go, thinks will be better with a bench tester,! Thanks for your advice
  15. Dtc D900 & failure to start

    Off to euro car to pick up a silver calcium I guess lol
  16. The remote on my 2010 fiesta has stopped working. I have changed the battery and tried to reprogram it. I have also had it checked at my local Ford dealer to see if it was transmitting a signal which it isn't. I assume I just need a new remote? However, I noticed today that the auto lock function that usually kicks after a minute or so if I don't open a door has also stopped working. Is this an indicator that I have a bigger problem? Thanks for any help or advice anyone can give me.
  17. Dtc D900 & failure to start

    It's a lion battery
  18. Windscreen wiper problems

    This happened to me twice after I retrofitted some Bosch aero wipers to my mk6.5 First time I believe it was my wax and after I replaced them this current time i think it was ice. Never had a single issue with my older ones. White vinegar is a very good idea, I used nail polish remover and it helped.
  19. Mk6 Fiesta Reversing light bulb fitting

    Tried a extender on your rachet?
  20. Instrument Cluster

    I was removing mine to change the light inside and broke the plastic on the front (very easily done). I believe if you do change for another one you need to change a few other things too. It's not very simple. Someone suggested to me I would likely need a new key and immobilizer. Not 100% sure if that's accurate but it swayed me away from doing anything else with the instrument cluster.
  21. Right hand dash display

    It is possible to turn off the central display on the right hand side of the instrument panel on the dashboard. I can turn the left off so I can see the full rev counter needle but not the right side so I can’t see the full speedo needle. The traffic sign display and forward distance radar don’t seem to have options to toggle them on and off. Unless of course someone knows better !
  22. Dtc D900 & failure to start

    I know someone who fried a cheapo non silver calcium battery in less than 2 months, I did tell him beforehand to get the right battery but he decided to be tight and buy the cheapest possible battery. Acid batteries and Ford "SmartCharge" is NOT a good combination
  23. Dtc D900 & failure to start

    Regardless of it's age it's still dead lol... Is it a Silver Calcium battery?
  24. Dtc D900 & failure to start

    Battery is only 3 months old!
  25. Dtc D900 & failure to start

    Battery is dead, I bet it starts from a jump. Dash codes are irrelevant btw, they're only codes actually for the dash, usually minor blips in the canbus, needs plugging in to get engine fault codes.
  26. Hi all after some wisdom... My 08 focus 1.8tdci failed to start this morning. Battery voltage is 11.8v so enough to get it going. However it's like the starter won't fire and it just goes womp womp womp dead. Checked the cluster got DTC D900 and from what I read it's a comms issue. So I need to get an obd on it. However, a garage fudge up earlier in the year led to them putting a used engine in the car. Never been right since but it was liveable. Could they have bodged some wiring when putting ye new engine in? It was the correct KKDA engine that was put in. Any thoughts before I end up with a £500 1.2 corsa?
  27. If you could have any car

    Focus MK3.5 ST3 petrol, that's all I want
  1. Load more activity