All Activity

This stream auto-updates     

  1. Past hour
  2. Things I Do Like

    Holy crud I would literally turn my pants brown if presented with a thousand quid bill for the car!
  3. Adams story game

    Congealed lump of phlegm
  4. Zetec S Rear Bumper & Skirt

    The NecroPoster strikes again!! Mwahahahahaaaaaaa!!! 😨😨😨😨
  5. Focus mk3 stop start not working

    I know mine is reluctant to enter s/s if I have the air con on... 11.4v is a flat battery mate so sounds like your monitoring system is out of whack. There is a procedure for resetting it involving pushing of buttons which might help. @iantt has posted about it before but I'll be buggered if I can find it... Edit: Here is what Ian put in another thread so Kudos to him if it solves your problem: Ron, if you want to have a go at reseting battery monitoring, just do as follows Ign on for 10 secs, press rear foglighr switch 5 times, press hazzard switch 3 times, wait 10 secs. Battery light flashes. Ign off use car, and see if thst fixes Full thread here so you can go and thank him! Lol!
  6. A few more questions for you all

    Actually I read that wrong. I read it as interior A and B pillars. If it's the bits on the outside of the car then work away. They are perfect surface for wrapping :) Sent from my SM-T810 using Tapatalk
  7. A few more questions for you all

    Cheers@Phil21185 I'm pretty sure the A and B pillars, being textured, won't be able to be wrapped. The surface needs to be smooth and almost glossy. 99% sure it won't work. On the other hand, the head unit surround, gearstick surround and door grab handlesncan all be wrapped. I have done this on my car with carbon fibre effect. Sent from my SM-T810 using Tapatalk
  8. Hi my stop start has stopped working. On the test menu it shows my battery as 11.4v with everything off. Is that healthy enough for the system to work. Done a 20minute trip down the motorway last weekend and had everything off as approaching the city and it still didn't activate. Anyone else had same issue. Or know a fix. Thanks
  9. Rear parking sensors mk3 (2013)

    you will indeed need a parking aid module, but before even buying anything you need to check if there is the 2 or 3 small multiplugs for parking aid module to plug into. some vehicles had them some didnt. bit more of a dig around on the o/s/r required. the plugs you see are not for parking aid
  10. Hello all, So today I was driving home from work for around 30 minutes some upto 40mph and some stop start traffic, when I pulled into a coffee shop I noticed that there was a rumbling noise when I turned the car off, I thought this was just a large vehicle going past on the motorway next to me and thought nothing of it. I then drove for another 30 mins in stop start traffic (my usual commute) and when I got home it did it again. There's no shaking in the car or steering wheel it just sounds like a low rumble, like if a large truck came past your window. I turned the car back on and then off and it didn't do it again - does anyone have any idea what could be causing this and if it is something to worry about? It's a 14 Plate Fiesta Petrol. Thanks in advance!
  11. A few more questions for you all

    Sorry I can't really help but I think this is one for Keifer! @kpg, you're up, bud! Actually lots of peeps have done nice wrap jobs inside and out so you should get a good answer soon.
  12. "usa Style" Side Lights.

    The NecroPoster strikes again!!! Mwahahahahaaaaaaa!!!😨😨😨😨 Actually @DJ_Andy_M is still pretty active here so you might get lucky with an answer!
  13. Rear parking sensors mk3 (2013)

    Thanks. Oh I'm confused as I've seen somewhere that it should go to a parking assist module in the drivers side boot behinds the little flap. I just checked mine b4 and found this not sure what that's for
  14. Back on ford owners club after 2 years

    They will look cool against metallic black car I'm. It too sure what colour would best suit my ink blue colour
  15. "usa Style" Side Lights.

    I would love for you to tell me how u got the badge to flip and the lights to work and what usrd for the lights
  16. Today
  17. Auto gearbox indicator

    is there a need to move the gear lever into s mode if you can change the gears whilst in d mode? whats the difference?
  18. Rear parking sensors mk3 (2013)

    You dont need the sat nav screen for rear sensors they work on even the monochrome screen, i imagine after having all the wires in place its just a matter of using the FoCCCus software to state you have rear sensors, you should also use FoCCCus to change the settings for the screen. This should be all you need to do. I dont think there is a seperate module for parking sensors however i may be wrong.
  19. Brake pedal play

    How are you going about bleeding the system? Maybe there is still air in there.
  20. Air Con Issue, Not working

    Thanks guys, ill get it looked at maybe tomorrow and see how it goes. Cheers
  21. brakes

    Ahh so maybe it is the drums, this is something ull have to make sure off.
  22. Mk3 mondeo 2.0 petrol whines

    Hi folks ive just bought my first petrol mondeo. It's a mk3 2.0 ghia. I have noticed a whining noise coming from the engine bay. It sounds very close to the dash - almost in it, on The drivers side. The car makes the noise when accelerating or revving the engine in neutral. However coasting or revving in neutral produces no whining noise. Could anybody please give me a suggestion as to where to look for the cause if the problem please. Thanks in advance:-)
  23. LED build change over.

    I'm glad I ordered the led headlights option now after reading how poor the halogens are. I just need to understand the autobeam thingy!!
  24. It's a line that bends but never breaks [emoji5] Sent from my SM-G930F using Tapatalk
  25. Thanks matey. I'll give that a go Love the thin blue line pic. That's my Facebook one.... Very thin these days lol
  26. "usa Style" Side Lights.

    Hi how did u get the whole grille working with flip badge and lights ?
  27. Hi folks I've had a couple of diesel mk3 mondeos in the past but have just bought my first mk3 petrol. I seem to have a worrying whine coming from the engine, not gearbox as it does it when revved in neutral but dissappears when coasting or on tickover. It sounds close to dash on the drivers side, but I'm sure it's got to be engine related. Can anybody please point me in the direction of the first places to look for the cause? Many thanks in advance. Nick.
  1. Load more activity