Help - Search - Members - Calendar
Full Version: Turbo On 2Liter Tdci 54Plate Not Cuttin In
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
davd
turbos not cutting in at required revs!!!!it just starts smoking,,its done 70 000 odd miles !!!!has any 1 had similiar problems with this engine????need some advice to rectify the problem!!!could it be sumthing else???like a sensor or sumthing else,,,dont really know where to start and i dont wnna be ripped off by the dealers!!!!i have had diesels in the past that have done far greater milege with no problems with regards to the turbo!!!the car still drive ,,,but i gtta avoid puttin my foot down,,as the smoke starts to billow out,,,plz plz help!!!!!
chris bowman
[quote name='davd' date='18 February 2010 - 06:26 PM' timestamp='1266516972' post='65629']
turbos not cutting in at required revs!!!!it just starts smoking,,its done 70 000 odd miles !!!!has any 1 had similiar problems with this engine????need some advice to rectify the problem!!!could it be sumthing else???like a sensor or sumthing else,,,dont really know where to start and i dont wnna be ripped off by the dealers!!!!i have had diesels in the past that have done far greater milege with no problems with regards to the turbo!!!the car still drive ,,,but i gtta avoid puttin my foot down,,as the smoke starts to billow out,,,plz plz help!!!!!
[/quote]


check the email ive sent u mate
tony b
[quote name='chris bowman' timestamp='1266539916' post='65691']
check the email ive sent u mate
[/quote]
seems similiar problem that i have, will start and drive but accelerate it smokes v badly and turbo seems to kick in at 2700rpm.
davd
[quote name='tony b' timestamp='1305104424' post='126710']
seems similiar problem that i have, will start and drive but accelerate it smokes v badly and turbo seems to kick in at 2700rpm.
[/quote]
ok if its smoking ,check your intercooler pipe , might be split thus causing the loss of power and smoke,,the pipe is located to the left of the radiator, and goes down parallel to the rad!
if it aint that or you cant find no splits then get your erg valve cheked, its probably clogged up,,get it taken off and cleaned with petrol,,dip it in petrol and clean it up properly!
if its not that then might be a turbo problem ,sometimes they start playing up etc ,it could be the fins are stiking??
good way to chek is to drive the motor and have the window down and wen the turbo cuts in at about 2000revs you can hear it,,,,if its making a clattery noise that means your turbos playing up,
if youve got a glow plug light on the dash that is flashing or a engine management lite flashing ,get the code read from a code reader,,some bak street mechanics do have them and then get bak to me with the codes or just look them up on the net!!

david


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615