Help - Search - Members - Calendar
Full Version: Mondeo 95' 1.8, Serious Pollution Problem
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
asaf.adler
Hello all,
I have a 1995 Ford Mondeo MK1.

The car has serious pollution problem. It's CO level is more than 10 times than allowed by law. (around 3.7%)
It also consumes too much gas, and its rpm (idle) is always higher than ir should - around 1300 rpm.

It suppose to be a common problem with this car - so maybe one of you knows the reason?

We looked at the oxygen sensor and it OK, also the catalytic converter and it's sensor is OK too.

Please assist.

Thank you very much!
Asaf.
chris bowman
[quote name='asaf.adler' date='19 February 2010 - 07:52 AM' timestamp='1266565320' post='65696']
Hello all,
I have a 1995 Ford Mondeo MK1.

The car has serious pollution problem. It's CO level is more than 10 times than allowed by law. (around 3.7%)
It also consumes too much gas, and its rpm (idle) is always higher than ir should - around 1300 rpm.

It suppose to be a common problem with this car - so maybe one of you knows the reason?

We looked at the oxygen sensor and it OK, also the catalytic converter and it's sensor is OK too.

Please assist.

Thank you very much!
Asaf.
[/quote]

could be many probs i had a mkii 1.8 and had to replace the lambda sensor, catalytic converter, and then we found that when the cat broke up it partially blocked the back box so that had to be replaced the following mot. this co however is extremely high! u havnt put an induction kit on and removed the intake sensor have u?
asaf.adler
both the catalytic and lambda were diagnosed ok.

No kit or so, though i removed the thermostat some years ago, but for years it worked fine.
The weather here is always hot so with or without thermostat does not make a difference.

Thanks,
Asaf.
chris bowman
i think its fuel mixture that is the problem. check intake pipes for air leaks. that is the big pipe either side of the air filter box.not sure if injectors could cause this but havnt heard of this problem with such low mileage. could try a decent petrol additive but if something is worn in the fuel system this could finish it off! would recommend code reading to try and identify the problem!


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615