Help - Search - Members - Calendar
Full Version: Chugging / Loosing Power - 1.8 Diesel
Ford Owners Club - Ford Forums > Ford Models > Ford S-Max Club
smaxdvdplayer
Has anyone had experience of the 2007 1.8 Diesel S-max chugging, and loosing power... (could not even overtake a lorry on the climbing lane going at 40 mph) across all gears (except 1st) above about 2000 revs? This has started with me after I drive the car for about 30 mins or more.... once the engine has warmed up. I have parked the car and am hoping to get it to a ford garage this week for diagnotic.
FORD 1
When my A3 did the same it was the diesel particulate filter on the exhaust.
artscot79
[quote name='FORD 1' date='22 February 2010 - 04:04 PM' timestamp='1266854078' post='66451']
When my A3 did the same it was the diesel particulate filter on the exhaust.
[/quote]

could be injectors and its in limp mode even a bdly blocked diesel filter or a sensor i think diagnostics is the best bet
smaxdvdplayer
[quote name='smaxdvdplayer' date='21 February 2010 - 10:56 AM' timestamp='1266749176' post='66105']
Has anyone had experience of the 2007 1.8 Diesel S-max chugging, and loosing power... (could not even overtake a lorry on the climbing lane going at 40 mph) across all gears (except 1st) above about 2000 revs? This has started with me after I drive the car for about 30 mins or more.... once the engine has warmed up. I have parked the car and am hoping to get it to a ford garage this week for diagnotic.
[/quote]

it was a blocked diesel fuel filter............ running 100% now.... cheers
artscot79
[quote name='smaxdvdplayer' date='23 February 2010 - 08:42 PM' timestamp='1266957157' post='66731']
it was a blocked diesel fuel filter............ running 100% now.... cheers
[/quote]


always nic when its the simple things


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.