I have a 98 Escort, runs very well no major issues until now but cannot pinpoint as it may be a number of causes. After using the car last week to travel on a 200 mile journey ( one I have done many a time) the following day when I was out i noticed that at idle every 10 seconds or so a very slight dip as if the engine was missing but it was so slight it was hardly noticeable. I thought it may be a faulty lead but I thought I would wait and see how it went, and it did not get worse over the next few days so I was not too concerned.
Anyway I then noticed that my car was low on water so i topped up but the next day the same thing happened again it was way below the minimum, i topped it up again and the following day it happened again, I also noticed that same evening i was out and at one point when idling the car made a slight chugging noise but this didnt happen again.

I have always thought the car had a tendancy to kick the fan in to soon when idling but the temp guage has never been in red only ever gone to 3 quarters and its fine on a run and in town.

Anyway I asked a mate who is a mechanic to look at it, he has checked the thermostat is working (I only replaced it 2 years ago) but he has said the water/coolant is not circulating plus there is a lot of pressure in the header tank. There is no leaks from anywhere and the oil cap and the dipstick are both clean no gunk on them also no oil in the water.
He reckons the thermostat may not be opening at the correct time, I have never heard of this and presumed it opened once the water heated up, so I thought I would ask for your advice as I personally am thinking i may be a head gasket going as I have seen this on a friends car yet my mate says no as there is no evidence in the oil.

Any advice is appreciated