Help - Search - Members - Calendar
Full Version: Escort Heater Gone U/s
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
Andy240
Hi there, Just gone to use my FORD ESCORT 55 D CAR DERIVED VAN 1753cc (12-09-2002) DIESEL and the heater has stoped working, and boy it's cold out there (must be getting old). I had this trouble on a works van before...It seems that the heater dial has no friction to it so I guess there is something under the dash that has come undone/broken. Any ideas as how to even get to it, hopeing I don't have to take the dash out...Any advace would be GREAT....Thanks.
CAR PARTS EXPRESS
firstly pull the heater knob off and check to make sure its not broken and just spinning on the shaft
Andy240
[quote name='FORD-PARTS-CENTRE' date='08 March 2010 - 09:39 AM' timestamp='1268040596' post='69542']
firstly pull the heater knob off and check to make sure its not broken and just spinning on the shaft
[/quote]



Hi there, Thanks for that, removed the heater knob, the knob itself is not broken, it's turning the shaft ok, it appears to be working some sort of 'flap' as when you turn it to the cold position the air comes through much quicker...There is a tiny amount of heat coming from the middle vents when in the 'hot' postion but such a tiny amount it can bearly be felt.....???????????
Andy240
Any ideas....Anybody/..
danwithaescortvan
when you say the heater is not working do you mean the fan does not work or the air is not hot if the fan is not working the chances are its the switch or the most common fault on escorts the fuse box is nackered check the switch first to get at it remove the knobs off the heater controls then undo the two screws above the speedo then prise off the suround gentley as the clips behind spring off once its off the switch is there hope ths helps let us know how you get on
Andy240
[quote name='danwithaescortvan' date='20 March 2010 - 10:47 PM' timestamp='1269124676' post='72827']
when you say the heater is not working do you mean the fan does not work or the air is not hot if the fan is not working the chances are its the switch or the most common fault on escorts the fuse box is nackered check the switch first to get at it remove the knobs off the heater controls then undo the two screws above the speedo then prise off the suround gentley as the clips behind spring off once its off the switch is there hope ths helps let us know how you get on
[/quote]
Andy240
Hi there, Thank you for your reply. The fan works fine, there is just no heat coming through, The 'knob' used to have resistance when you turned it but no longer. Is there a valve of some sort that sould be opperated by the knob? Andy.
vinnyvangough
Cant remember which side it is, but check in the footwells that the connecting wire hasn't come off.
If you look in the footwell, each side of the centre consul, when you turn the hot/cold dial, the drivers side valve will move, if you turn the right hand dial the one in the passenger footwell should move.

Check them.


Full Colour Version: Escort Heater Gone U/s
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615