Help - Search - Members - Calendar
Full Version: Speedo
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Focus-Tony
Im guessing you get a topic like this every single day lol

but on my mk1 ford focus 1991 my speedo has comply stoped working and every now and again it may work for a couple miles

and also my miles aint going up aswell

i have changed the speedo sencor on the gearbox but it still isnt working iv check the wiring behind the clocks and everything is fine

everything else on the clocks is fine eg petrol, revs, temp gages r all working apart from speedo

so can anyone else help??

Many thanks tony
HeadShoT2009
What the focus was out in 1991 I thought it came out 1998/1999
mjt
I had a similar problem. The speed sensor and instrument panel were replaced but it still happened. It was eventually traced to a chafed wire from the speed sensor where it passes close to the gear selector. Might be worth a look.
Knight Focus
[quote name='HeadShoT2009' date='18 March 2010 - 10:10 AM' timestamp='1268906408' post='72231']
What the focus was out in 1991 I thought it came out 1998/1999
[/quote]
I assume that was a typing error! :P

Mike
Focus-Tony
hahaha yh my bad lol, 1999 i ment sorry lol

ermm some has told me 2 change my clocks but tbh i think its gonna be pointless, cos the speedo dose work every now and again wen it fells like it :S
Focus-Tony
i went scrap yard 2day got new speedo clocks and it still isnt working :S so im clueless atm and ideas???
artscot79
[quote name='Focus-Tony' date='20 March 2010 - 03:15 PM' timestamp='1269097546' post='72725']
i went scrap yard 2day got new speedo clocks and it still isnt working :S so im clueless atm and ideas???
[/quote]


im nt aware of anything else other than fuses and relays the vss is the usual suspect so im stumped too mate
Focus-Tony
[quote name='artscot79' date='20 March 2010 - 03:29 PM' timestamp='1269098346' post='72726']
im nt aware of anything else other than fuses and relays the vss is the usual suspect so im stumped too mate
[/quote]

im gonna give the fuses another shot but i do dout it is them as the speedo dose work wen it fells like it :S
Focus-Tony
[quote name='Focus-Tony' date='20 March 2010 - 03:39 PM' timestamp='1269098971' post='72729']
im gonna give the fuses another shot but i do dout it is them as the speedo dose work wen it fells like it :S
[/quote]

i have double checked the fuses and it isnt then, i am thinking and hoping it is a dodgy speedo sensor that i have got, so im gonna get another 1 and try it
Focus-Tony
it was the wiring loom


Full Colour Version: Speedo
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.