Help - Search - Members - Calendar
Full Version: Idle Speed Sticks
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
mjcarter73
Hi Y'all. Recently the idle speed on my ford escort estate (2000, finesse 1.6) has started to stick :unsure: - starts and drives normally, but when stopping the engine remains racing at whatever max setting was achieved by the throttle during the drive :angry: . In this state if you increase engine speed using the pedal it sticks at the new maximum. Usually it will unstick and drop down again after a few minute. Alternatively a quick engine rev can sometimes unstick it- but not always and can just set a higher stick value (as before) :( . It doesn't seem to be a sticking cable or carb throttle link as raising the pedal to pull the cable back doesn't do anything. I have read about an "idle control valve" which can stick but don't know if this model even has one? Alternatively is this an auto choke problem? Any ideas anyone?
Mike
vinnyvangough
More than likely the idle control valve.

Very common problem, take it off, give it a clean, reset the ECU by disconnecting the battery for 30 mins or so and see how she goes then
mjcarter73
[quote name='vinnyvangough' date='18 March 2010 - 03:43 PM' timestamp='1268926403' post='72286']
More than likely the idle control valve.

Very common problem, take it off, give it a clean, reset the ECU by disconnecting the battery for 30 mins or so and see how she goes then
[/quote]
mjcarter73
Thanks thats sounds very likely- but where is the thing? Its not listed on the Haynes manual at all??

Thanks

Mike
vinnyvangough
I am unsure where it is located on the 1.6. On the 1.8 it is under the inlet manifold at the rer of the ngine.

Try looking on wwww.fordescortclub.co.uk as they have covered this issue many times
jedamotorsport
[quote name='vinnyvangough' date='19 March 2010 - 07:22 PM' timestamp='1269025931' post='72564']
I am unsure where it is located on the 1.6. On the 1.8 it is under the inlet manifold at the rer of the ngine.

Try looking on wwww.fordescortclub.co.uk as they have covered this issue many times
[/quote]

Same place Vinny,as on the 1.8 as far as I`m aware.
Hows things m8?

Jeff
vinnyvangough
Hello stranger, hows tricks?
Yea not going bad bud, scrapped the mk6 ghia due to rust, but got myself a 1985 xr3i mk3 cabby now.
How about you?
10arnoldj
i have a 1998/R escort finesse 1.6 16v Zetec and had the same problem. Its only first thing in the morning though when engines cold, My advice is to just let her tick over for about 15minutes to warm up the cold start injectors, thus the engine will run properly then and will not idle funny. Still the Idle Control Valve is located just infront of the coil pack on our engines. its a small Square/ish black thing with 2 wires going into it. Just unplug it and Spray with carb cleaner or something similar. The attatched image shows where it is (RED CIRCLE) ( i also know our engine doesnt have the EFI Unit at the back, instead just the Black Hose that goes straight to the filter box but google images didnt have a pic of ours)
racer
Neep help 1998 finesse idle speed valve where is it any one thanks
racer
Neep help 1998 finesse 1.6i idle speed control valve where is it any one thanks

Bob Parker
i also have a 1998 finesse 1.6 16v and am having high revs when idling until the engine warms up, id also like to know the location of the idle control valve so i can attempt to clean it.
stevie123
Thats not the idle speed control valve in the picture, its located on the throttle body, remove it and clean, problem probably throttle position sensor tho.


Full Colour Version: Idle Speed Sticks
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.