Help - Search - Members - Calendar
Full Version: Power Steering Malfuntion
Ford Owners Club - Ford Forums > Ford Models > Ford S-Max Club
stephencooper
I have had my Ford S-Max Titanium 56 from new and had many,many problems from wipers going off even with no key in,windows staying down,sensors not working,air bag malfuntion,brake bulbs always going,front lights malfuntion,boot locking for days on end.With all these problems solved i was looking forward to happy days,until this morning on the school run i got a steering malfuntion then the steering locked up,i stopped the car scratching my head,so i turned the engine off and started again with no probs,managed getting kids to school and got home with no more hiccups,does anyone have any idea as to a possible solution,,,really dont want to give car up as i love it.
tunne1rat
Is it the 2.0tdci by any chance?
If so sorry to be the bearer of bad news but your electric power steering pump is on its way out.
stephencooper
[quote name='tunne1rat' date='03 April 2010 - 03:05 PM' timestamp='1270306543' post='75861']
Is it the 2.0tdci by any chance?
If so sorry to be the bearer of bad news but your electric power steering pump is on its way out.
[/quote]
yep you were right the pump has finally gone which makes driving near impossible,ordered a new one from ford which was 100 cheaper than i could find on ebay, but it still breaks my heart as im only 4 weeks out of warrenty :(
Dawnl
Hi ya,
Just out of interest I noticed from your catalogue of problems you mentioned the boot locking, just wondered what the solution was only,
mine locked up only the once but at the time I was transporting a BBQ to my brothers house and we had to dismantle the BBQ in the car to get it out and two days later as I was driving down the road the luggage department warning light came on and the boot had released. not had the problem again but just interested to see if you found the cause.
noddy
[quote name='Dawnl' date='07 August 2010 - 10:31 PM' timestamp='1281216065' post='91852']
Hi ya,
Just out of interest I noticed from your catalogue of problems you mentioned the boot locking, just wondered what the solution was only,
mine locked up only the once but at the time I was transporting a BBQ to my brothers house and we had to dismantle the BBQ in the car to get it out and two days later as I was driving down the road the luggage department warning light came on and the boot had released. not had the problem again but just interested to see if you found the cause.
[/quote]

Dawnl,

I have had this too- amongst many other snags. I found it occurred mostly when I tried to shut the boot with something in it pushing against it, e.g. a buggy, so I had to really slam it shut. Once it was shut, you guessed it, couldn't open it! The best soltuion I found is to push the boot lid in/down just above the button to take the pressure off the catch while at the same time pressing the release button. Be careful though because if you push too hard the surface does not seem to be the strongest so don't crack it.
mr ccc

i also have the power steering malfunction message on start up its a nightmare as one time i had to get the car onto our driveway as you can imagine with no power steering this was hard work lol although iff i turn key off then on a few times the steering is ok as ive heard some module or whatever in the electric pump doesnt wakeup as you turn on the ignition ? and i was woundering iff these pumps are seviceable as this is the second time this has happened to me i still have my old one in the shed from 3 yrs ago these pumps are very expensive to buy that is why i was woundering iff anybody has any idea about them being repaired with an updated part inside



Full Colour Version: Power Steering Malfuntion
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615