Help - Search - Members - Calendar
Full Version: St170 Instrument Cluster Fault
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
clb7
hi, can anyone help with this problem,, over the the last 2 months or so the speedo, rev and fuel needles only worked every now and then. its now got to the point were they rarely work at all..the mileometer also dosent come on...all the lights work its just the needles that dont..ive removed the cluster and cleaned the circuit board but this hasnt made any difference... has anyone got any ideas on what could be wrong? or do i need a new instrument cluster..any help would be great

cheers
artscot79
[quote name='clb7' date='30 March 2010 - 07:46 PM' timestamp='1269974209' post='75075']
hi, can anyone help with this problem,, over the the last 2 months or so the speedo, rev and fuel needles only worked every now and then. its now got to the point were they rarely work at all..the mileometer also dosent come on...all the lights work its just the needles that dont..ive removed the cluster and cleaned the circuit board but this hasnt made any difference... has anyone got any ideas on what could be wrong? or do i need a new instrument cluster..any help would be great

cheers
[/quote]


take it to ford if it is the cluster they have to replace it at a cost of 99 only as it was reported on watchdog


Full Colour Version: St170 Instrument Cluster Fault
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615