Help - Search - Members - Calendar
Full Version: Dashboard Indicators & Heated Front Windscreen Problems
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Smittie
[size="5"][b]Ford Focus 2003 lx [/b][/size]

[size="4"]On the dashboard the Battery light indicator comes on after 20 - 30 seconds

& Brake/Handbrake light indicator is intermittent

Heated front windscreen works ok on start up until the battery light indicator shows

The Battery and Alternator have been checked twice also I have cleaned the cluster board behind the dashboard with Electrical cleaning spray.


Still getting the problems, hope you can help?

[b][color="#0000ff"][u]Reply to Artscot79[/u][/color][/b]
I Have Checked the Battery type its a [b]MotorCraft SuperStart 12volt 390Amp EMF 543025039w[/b] not sure if is a Silver Calcium battery?

[color="#ff8c00"][u][b]Update 18/04/10[/b][/u][/color]
Changed my Battery to a Bosch Silver Calcium still getting the dashboard faults?
[/size]
artscot79
[quote name='Smittie' date='17 April 2010 - 05:33 PM' timestamp='1271521402' post='78154']
[size="5"][b]Ford Focus 2003 lx [/b][/size]

[size="4"]On the dashboard the Battery light indicator comes on after 20 - 30 seconds

& Brake/Handbrake light indicator is intermittent

Heated front windscreen works ok on start up until the battery light indicator shows

The Battery and Alternator have been checked twice also I have cleaned the cluster board behind the dashboard with Electrical cleaning spray.


Still getting the problems, hope you can help?
[/size]
[/quote]

simply check youre battery if its a lead acid battery its the wrong type it must be silver calcium/lead calcium battery due to the smart charge which over time toasts normal batteries and gives you the kind of issues youre having right now most places dont have a clue about the battery or th esmart charge if you went to ford youde find that they will sell you silver/lead calcium battery whereas because they are cheap most places such as halfords will recommend lead acid batteries if yiou have the correct battery then you will neeed to take it to ford who will cjheck it and if they find a cluster fault have to replace it at a cost of 99 pouinds
hawker
I had exactly the same problem with mine.
Your alternator is gone mate. Get it checked again elsewhere
Probably looking around £200 to fix
artscot79
[quote name='hawker' date='17 April 2010 - 09:55 PM' timestamp='1271537125' post='78186']
Your alternator is gone mate. Probably looking around 200 to fix
[/quote]


check the battery first many a car has had new alternators with these symptoms to find they still exist if its a lead calcium or silver calcium battery then have ford test the alternator properly if its a lead acid battery get the proper battery first


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.