Help - Search - Members - Calendar
Full Version: Changed Mondeo diesel Fuel Filter - Wont start
Ford Owners Club - Ford Forums > General Forums > Maintenance / Servicing / MOT Discussions
alcutler
Hi today I have changed the fuel filter on my sons 1997 1.8TD Mondeo Ghia X - All seemed to go well until I tried to start it and it refused to start. I have primed the pump on top of the filter and eventually it will start and run for about 5 seconds and then stops - any suggestions please
mintalkin
remove the left hand pipe on the filter
then pump the primer tit on the fuel filter housing until fuel squirts out of the pipe you removed, then put the pipe back on (this bleeds the air out of the system)

the car should start and run fine. if it doesnt, it means you have misaligned one of the rubber rings and got air in the system. hope this is of assistance
alcutler
[quote name='mintalkin' post='2803' date='Aug 13 2008, 09:16 PM']remove the left hand pipe on the filter
then pump the primer tit on the fuel filter housing until fuel squirts out of the pipe you removed, then put the pipe back on (this bleeds the air out of the system)

the car should start and run fine. if it doesnt, it means you have misaligned one of the rubber rings and got air in the system. hope this is of assistance[/quote]
alcutler
Thanks for your reply - I had tried that - The 'tit' when primed was allowing fuel to escape and obviously letting air in - I got a replacement filter housing from local breakers replaced it and all ok now. I assume the primer was on its last legs and when I primed it this time it finished it off.
mintalkin
glad you sorted it


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615