Help - Search - Members - Calendar
Full Version: Cruise Control Button Not Working
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
GrahamH
Travelling down the motorway went to turn on the cruise and the On button does not work. Strange thing is that when I press + and - button together(right hand side steering wheel) it comes on then I press 'set/+' and it works just as normal. Off button works fine as does brake and clutch switch. Is it just the On button? Where can I find a wiring diagram to check this button without having to remove it first?
As an aside, tavelling at a steady 80-85 on cruise for approx 80 miles trip computer shows average fuel consumtion as 53Mpg, now that I like:-)
mintalkin
when you say it wont switch on do you meen you do not get the symble on the dash? as this does not come on untill you press + or -, see attached
GrahamH
[quote name='mintalkin' date='16 May 2010 - 08:58 AM' timestamp='1273999698' post='82077']
when you say it wont switch on do you meen you do not get the symble on the dash? as this does not come on untill you press + or -, see attached
[/quote]
ah, may have done a Dilbert. Will try it again tomorrow. I always thought the symbol came on with the 'On' button.
Thanks
GrahamH
tried it again today and is exactly as you said. Light comes on when selecting 'set' and not when selecting 'on'
many thanks for your assistance.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.