Help - Search - Members - Calendar
Full Version: Weak Turbo
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Bagheera
After a regular maintenance service for 45.000kms, held by the official dealer's garage, my Focus doesn't feel the way I am accustomed to. All the filters, oil and the turbo pipe were nenewed, they say, but somehow the turbo doesn't just pull the car in a punchy manner. The car had just been better before service! What could have possibly gone wrong with it and how am I gonna restore the original power and torquey feel?

Thanks.
Bagheera
So I guess every TDCI works fine there :) Well, lads, I visited another official dealer today, they installed a software to fix the problem which I noticed no big difference soon afterwards, and the mechanic told me the CKP sensor may need to be replaced. There's also another sensor as CMP. Any tech-savvies here, would they please tell me what they stand for and if these sensors are related with the loss of power? Any ideas appreciated.
jeebowhite
CKP is the CrankShaft Position Sensor, the CMP is the Cam Shaft Position Sensor, it could well be that they are detecting a higher pressure, possibly due to higher resistance, this would then tell the cars computer that it wont need any more power putting through. Other than that, it could just be reading it wrongly, and maybe the computer knows its reading it wrongly, and so is limiting its own performance for safety. Other than that, I would check using the dashboard trick (on the first page) to check that the sensors are or are not being detected with errors.
Bagheera
[quote name='jeebowhite' date='29 May 2010 - 10:23 PM' timestamp='1275160428' post='83574']
CKP is the CrankShaft Position Sensor, the CMP is the Cam Shaft Position Sensor, it could well be that they are detecting a higher pressure, possibly due to higher resistance, this would then tell the cars computer that it wont need any more power putting through. Other than that, it could just be reading it wrongly, and maybe the computer knows its reading it wrongly, and so is limiting its own performance for safety. Other than that, I would check using the dashboard trick (on the first page) to check that the sensors are or are not being detected with errors.
[/quote]

Thank you. I had checked using the trick, however, no fault codes were shown. I feel as if I drive an essence 1.6. Will see the dealer once again next weekend and have the sensor(s) renewed.
jeebowhite
Im quite interested in this one, so please let is know what happens when you do get it checked!
Bagheera
[quote name='jeebowhite' date='31 May 2010 - 09:47 PM' timestamp='1275331045' post='83785']
Im quite interested in this one, so please let is know what happens when you do get it checked!
[/quote]

Last weekend I paid another visit to the same dealer I had been before. They replaced the air filter inlet valve - some part close to the turbo pipe under warranty. If it wasn't for the warranty, however, it would cost a hefty 380 TL, equivalent of 170 GBP approx. Now the car seems better.


Full Colour Version: Weak Turbo
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615