Help - Search - Members - Calendar
Full Version: Washers Not Working
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
mickmcd26
My windscreen washers not working on the front or back screens,you can hear the motor working but water just dripping out of the jets.Tried pins in the jets,makes no difference
artscot79
[quote name='mickmcd26' date='23 May 2010 - 04:22 PM' timestamp='1274627559' post='82891']
My windscreen washers not working on the front or back screens,you can hear the motor working but water just dripping out of the jets.Tried pins in the jets,makes no difference
[/quote]


either the pump then or a break in the hose somewhere
wingman
[quote name='mickmcd26' date='23 May 2010 - 03:22 PM' timestamp='1274627559' post='82891']
My windscreen washers not working on the front or back screens,you can hear the motor working but water just dripping out of the jets.Tried pins in the jets,makes no difference
[/quote]

HI
I had the same problem.It could be a blocked washer bottle filter. You need to take out the resevoir and clean it through and take out the filter also blow out any gung in the washer lines. Is The washer fliud showing black bits sludge? If so this is due to the screen wash been conaminated, or due to it been frozen up and then thawing over the winter months.Mine is now working fine.
Hope it helps.


Full Colour Version: Washers Not Working
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.