Help - Search - Members - Calendar
Full Version: Heated Front Screen Only Works In One Side
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Zemich
Hi everyone
I've just bought a Ford Focus 1,6 TDCi from 2007.
Today I discovered that my heated front screen only works in the passenger side. My first thought was that it must be because one of the fuses where broke.
They both looked good, but I tried to switch them anyway, to see if the problem then would have been in the passenger side. But no, it is still only works in the passenger side.
It is a brand new windscreen, so my next guess is that the ones who installed the windows, forgot one of the connections.
But my question is, where is it connected?
Don't wanna go back to the dealer unless it is really necessary.
Hope some of you can help. :)
I will fix it!
[quote name='Zemich' date='28 May 2010 - 08:43 PM' timestamp='1275078806' post='83497']
Hi everyone
I've just bought a Ford Focus 1,6 TDCi from 2007.
Today I discovered that my heated front screen only works in the passenger side. My first thought was that it must be because one of the fuses where broke.
They both looked good, but I tried to switch them anyway, to see if the problem then would have been in the passenger side. But no, it is still only works in the passenger side.
It is a brand new windscreen, so my next guess is that the ones who installed the windows, forgot one of the connections.
But my question is, where is it connected?
Don't wanna go back to the dealer unless it is really necessary.
Hope some of you can help. :)
[/quote]

Hi,

Remaove both scuddle panels and there will be a wire at the bottome of the screen, that wire needs to br rerooted when fitting the screen to prevent this happening. Check all coneections are in, if so it could be a faulty screen. Is it a ford screen that was fitted? If so it will be warranty. But it sounds like they have forgot to reroot the connections! take it back to the dealer and they have to do it free of charge.
heavyoiler
[quote name='Zemich' date='28 May 2010 - 08:43 PM' timestamp='1275078806' post='83497']
Hi everyone
I've just bought a Ford Focus 1,6 TDCi from 2007.
Today I discovered that my heated front screen only works in the passenger side. My first thought was that it must be because one of the fuses where broke.
They both looked good, but I tried to switch them anyway, to see if the problem then would have been in the passenger side. But no, it is still only works in the passenger side.
It is a brand new windscreen, so my next guess is that the ones who installed the windows, forgot one of the connections.
But my question is, where is it connected?
Don't wanna go back to the dealer unless it is really necessary.
Hope some of you can help. :)
[/quote]
Mine was the same. Garage sent a guy out to fit a new windscreen. What had happened was the wiper arm linkage had torn the connector off on the drivers side. It needs to be routed above the linkage, which when mine had its last windscreen fitted wasn't!


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.