Help - Search - Members - Calendar
Full Version: Speedo Goes To Zero Any Advice?
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
bex51focus
hi ive got a 51 plate focus, 1.6 zetec. ever since i got it the speedo keeps dropping to zero it is happening more and more but then sometimes wont happen for few days. i have read and heard that ford focus`s do have problems with the dash. any advice on what to do. was going to have new vehicle speed sensor fitted last week but garage said it wont necessarily fix the problem, so didnt have it done. it is only the speedo that drops the radio volume also goes lower too. but no other gauges drop. pls help shed some light on what i can do. thanks.
jeebowhite
The focus has a AVL feature I think its called Auto Volume leveling, but thats linked to speed, sounds like its not being picked up at the gearbox...
C-Max Boy 1983
Your problem is the VSS (Vehicle Speed Sensor) which you need to replace ASAP, I have heard of horror stories where the car will just cut out one day and you lose all the power, I had this problem on my Focus Zetec, I think it is a cheap fix as well and if you confident with a spanner then you should be ok to replace this yourself.

Davy
bex51focus
hi i was going to get it done last week for 70 quid, but the garage said it most probably wont fix the problem as they have had problems with the dash and only ford can fix it for 300 quid. not sure what to do dont want to pay 70quid and it dont fix it. it apparently something to do with the lead in the solder used when the speedo unit was made. any more advice?
bex51focus
hi i was going to get it done last week for 70 quid, but the garage said it most probably wont fix the problem as they have had problems with the dash and only ford can fix it for 300 quid. not sure what to do dont want to pay 70quid and it dont fix it. it apparently something to do with the lead in the solder used when the speedo unit was made. any more advice?
adz01
definetely sounds like a VSS to me, :s
mintalkin
VSS
TECHY7
Hi,

I have had both problems ie; problems with the DASH and problems with the VSS.
My car is a 03 Focus 1.6 Ghia (petrol)
The problem with the dash seems to effect this year mainly, and the prolems I had with it were not confined to just the speedo, and were caused by corrosion of the VIAs on the printed circuit board starting to corrode.
The problem with the VSS and the thing I think is most likely your problem, will effect the speedo and the radio, in my case both would suddenly increase then drop back down again to normal.
The reason the radio increases is because the VSS sends a signal to the ECU which in turn sends a control signal to the radio's volume control circuit, the idea being the faster the car goes the more road noise etc; is generated so the radios volume is turned up to compensate, and vise-versa.
The VSS is not a big job to replace but it is slightly difficult to get at.
Hope this helps.

Regards,

Techy7.
artscot79
[quote name='TECHY7' date='14 June 2010 - 04:55 PM' timestamp='1276530305' post='85124']
Hi,

I have had both problems ie; problems with the DASH and problems with the VSS.
My car is a 03 Focus 1.6 Ghia (petrol)
The problem with the dash seems to effect this year mainly, and the prolems I had with it were not confined to just the speedo, and were caused by corrosion of the VIAs on the printed circuit board starting to corrode.
The problem with the VSS and the thing I think is most likely your problem, will effect the speedo and the radio, in my case both would suddenly increase then drop back down again to normal.
The reason the radio increases is because the VSS sends a signal to the ECU which in turn sends a control signal to the radio's volume control circuit, the idea being the faster the car goes the more road noise etc; is generated so the radios volume is turned up to compensate, and vise-versa.
The VSS is not a big job to replace but it is slightly difficult to get at.
Hope this helps.

Regards,

Techy7.
[/quote]


you can get the cluster repolaced for 99 quid including labour if its faulty
TECHY7
[quote name='artscot79' date='14 June 2010 - 07:27 PM' timestamp='1276539448' post='85141']
you can get the cluster repolaced for 99 quid including labour if its faulty
[/quote]
Hi artscot79,

Thanks for the info.
Yes I am aware that I could get the cluster replaced for 99, but I had taken my cluster out and repaired it before all the publicity on television (Watchdog, RAC Forum etc;) and it has been okay since.
I was also concerned about the mileage being incorrect after a new cluster has been fitted.
I did take photographs just as a mattetr of interest.

Regards,

Techy7.
alz
Do you also lose power when speedo goes to zero
TECHY7
[quote name='alz' date='14 June 2010 - 08:38 PM' timestamp='1276543734' post='85151']
Do you also lose power when speedo goes to zero
[/quote]


Hi alz,

No I did not lose power.

Regards,

TECHY7.

P.S. Sorry alz not sure if you were asking me as your question appeared in my Inbox. If you were not I apologize.

TECHY7.


Full Colour Version: Speedo Goes To Zero Any Advice?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.