Help - Search - Members - Calendar
Full Version: Handbrake Cable
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Jonp81
Hi guys just joined the site :)

Got a right weird handbrake problem in my 05 MK2 Focus

Went to tighten it as it was screeching, tighted it once and it seemed a little better, then put the handbrake surround back on tried it and it just went loose.

So here I was thinking maybe it had come loose, so I took all the center console out to get a better look, not quite sure whats happened, but if I pull the cable by hand I can hear the rear brakes squeak a bit so I dont think theres a cable break?

Anyway a pic might help explain it better, any help is much appreciated.

I know the square bit where the cable is joined should be in the metal part of the handbrake, it fits in there quite snug, but how is there that much excess (look how high the handbrake is)? I barely moved the bolt a few mm, so I am really puzzled on what has happened and how to fix it.

[url=http://img685.imageshack.us/i/img1678v.jpg/][img]http://img685.imageshack.us/img685/1899/img1678v.th.jpg[/img][/url]


Direct link to large image [url]http://img685.imageshack.us/f/img1678v.jpg/[/url]

PS : sorry about all the grime its amazing how much rubbish has got under the trim!
DAS
looks as if you've got a broken cable, if it only brakes at one side you can still pull the other side on. jack the car up and get someone to try and spin each rear wheel as you pull the cable. thats all i can think of.


Full Colour Version: Handbrake Cable
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615