Help - Search - Members - Calendar
Full Version: Loss Of Power
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
degsy.
My mondeo has recently developed a fault where as soon as the engine warms up the temp gauge slowly slides back to zero and the car then seems to run on greatly reduced power with the electric fan whirring constantly, even for a good few minutes after the engine is switched off.
I contacted a local ford main dealer who, after running a diagnostic ( which showed no fault codes), advised me the water pump and power steering pump would need to be replaced to cure the problem.
The ford dealer carried out the work at a cost of 653.02p saying the problem was sorted and the car had been road tested.
After collecting the car I got less than 2 miles before the car did exactly the same thing again, I turned the car around and went back to the garage, I asked them to return the payment to my debit card until the problem was sorted as I firmly believe I have paid for work that was not needed, the garage refused to return my payment and have since been carrying out more diagnostics that so far seem to have them stumped so they are now in touch with Ford UK to see if they can shed any light on the problem.
My question therefor comes in 2 parts, firstly, do you have any idea what the problem is?? ( according to the ford garage it is not the cyl head temp sensor ),
and secondly, where do I stand on getting any money repaid if any work done was unnecessary.

Many Thanks

Degsy.
mintalkin
the temp gauge creeping back is usually signs of a thermostat playing up,on the tdci there are two thermostats, the standard coolant one and an oil cooler thermostat.its usually the oil cooler one that plays up.


Full Colour Version: Loss Of Power
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.