Help - Search - Members - Calendar
Full Version: 2002 Focus With 1.6 Zetec Se Engine
Ford Owners Club - Ford Forums > General Forums > Maintenance / Servicing / MOT Discussions
SeanyCozzie24V
well this problem has just started tonight. i was driving along and then the car started chugging really badly and the battery and oil warning lights came on. the car started to cut out. can anyone shed light on this problem?? also i put £35 worth of petrol in it on friday and it has only done 190 miles??
artscot79
[quote name='SeanyCozzie24V' date='05 July 2010 - 02:14 AM' timestamp='1278291866' post='87059']
well this problem has just started tonight. i was driving along and then the car started chugging really badly and the battery and oil warning lights came on. the car started to cut out. can anyone shed light on this problem?? also i put 35 worth of petrol in it on friday and it has only done 190 miles??
[/quote]

apart from making sure the oils fine have the battery tested is it a genuine ford silver calcium lead/calcium battery or is it a lead acid battery you can only uise silver calcium lead acid batteries fry and fail which is a possibility its hard to diagnose mate youre best doing the dash trick and see if any codes were stored on the dash but a diagnostic is what you need
stef123
sounds to me like an ignition coil failure.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.