Help - Search - Members - Calendar
Full Version: Squeaking engine
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
cardi
I have this steady squeaking coming from the engine compartment. It is regular so must relate to engine rotation. I suspect tensioner pulley but with this weather I haven't had a chance to look, remove belt etc. Water pump maybe. Anybody had similar experience. Engine is Endura diesel turbo.
mintalkin
most likley a tensioner,water pump bearing or the belt itself
vinnyvangough
Be weary of the fuel pump, they are know to go and squeak. Just took my TD lump out today. But as said, could be the tensioner.
cardi
[quote name='vinnyvangough' post='3387' date='Sep 7 2008, 01:10 AM']Be weary of the fuel pump, they are know to go and squeak. Just took my TD lump out today. But as said, could be the tensioner.[/quote]

Is that the lift pump? I hope you don't mean the injector pump.
The thing is that I am off to south Italy next week and want to get the vehicle sorted. I have a low mileage Fiesta for scrapping with a good non turbo engine. Does anyone know if there is much difference from the turbo? I wll probably pull offf all the bits to take as spares.
vinnyvangough
No the injector pump. There is a difference between the 2 pumps on the engines and i have heard the internals are slightly different but i'm not 100%.
In america they run these TD engines with bigger turbo's and up the boost to 100 psi and they run on standad internals at 10 sec quarters!!!!!!
cardi
It looks like it was the belt. I took it off and there was no squeak so turned it around and it's OK. Thanks for the ideas.


Full Colour Version: Squeaking engine
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615