Help - Search - Members - Calendar
Full Version: Abs Light & Speedo Pulsing
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Marky Mark
Hi, I've been having consistent problems with my Ford Focus Titanium (2005)for a while now and was hoping someone could guide me in the right direction!

The ABS warning light has been coming on sporadically for the past year or so. I have had the sensor replaced, and more recently the brake pads replaced and discs checked (all ok). But the ABS light still comes on, usually preceded by a pulsing of the speedo. Turn off the engine and the light goes off for a while, sometimes days, and then teh cycle starts again.

Does anyone think this could be due to corrosion of the Instrument Cluster? The various garages just charge me 30 to wipe the code and say its fixed! Any help or advice would be gratefully received.

Mark
mintalkin
sounds like one of the abs sensors starting to fail or rust/damage on one of the sensor rings.
Marky Mark
[quote name='mintalkin' date='15 July 2010 - 03:16 PM' timestamp='1279206375' post='88513']
sounds like one of the abs sensors starting to fail or rust/damage on one of the sensor rings.
[/quote]

Cheers, but would this problem have an effect on the speedo too?
DAS
yeah, the speedo uses the wheel speed sensors to measure the speed on your year focus.
Marky Mark
[quote name='DAS' date='20 July 2010 - 04:54 PM' timestamp='1279644265' post='89201']
yeah, the speedo uses the wheel speed sensors to measure the speed on your year focus.
[/quote]

Thanks for both the replies! Cheers.


Full Colour Version: Abs Light & Speedo Pulsing
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.