Help - Search - Members - Calendar
Full Version: Mondeo Engine Problems
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
karl58
Hi all, new to this website and hope someone can help me.
my mondeo mk2 engine keeps cutting out while driving, i can start it up again and it may last 2mins to 10mins, is it dirt in the carb, petrol filter ?
need help please. can email me here or at
eastmidscouple@hotmail.co.uk
or
karl.atkin@googlemail.com
thanks
karl
wimiu012uk
[quote name='karl58' date='28 July 2010 - 03:40 PM' timestamp='1280331023' post='90311']
Hi all, new to this website and hope someone can help me.
my mondeo mk2 engine keeps cutting out while driving, i can start it up again and it may last 2mins to 10mins, is it dirt in the carb, petrol filter ?
need help please. can email me here or at
eastmidscouple@hotmail.co.uk
or
karl.atkin@googlemail.com
thanks
karl
[/quote]

I think this may have been covered before, but it could be the fuel tank breather blocked. Try driving with the fuel cap off, obviously not when brim full and not aggresive round corners. If this cures the problem you know what the answer is. Also if when opening fuel cap you may hear a hiss which would also indicate a blocked fuel breather.
Hope this helps.
karl58
thanks for that but i have already checked that and its all ok, i was thinking of dirt in the carb or fuel filter, someone has also mentioned a fuel injector
stef123
[quote name='karl58' date='28 July 2010 - 06:13 PM' timestamp='1280336623' post='90323']
thanks for that but i have already checked that and its all ok, i was thinking of dirt in the carb or fuel filter, someone has also mentioned a fuel injector
[/quote]

IIRC the mondeos might have had a prob with the crank position sensor, that could cause the car to cut out


Full Colour Version: Mondeo Engine Problems
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615