Help - Search - Members - Calendar
Full Version: Failing Oil Pressure??
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
fish4tea
whilst driving home last night when approaching a roundabout the oil pressure light flickered on, stopped checked levels all ok,got home about 1/2mile away ok,this morning started it up all ok,as the oil warms up the light flickers on when engine is doing less than 1000rpm, 1000rpm and over it goes out, engine seems ok, no overheating, no nasty smells, oil seems to be getting to the top of the head ok, all sounds as it did quite sweet for a diesel,oil is 5-30 from ford
does not have any nasty knocking from the big ends main bearings or rattly top end in fact it sounds nice and smooth so am wondering if its a oil pressure sender failing or has someone else got any better ideas
did see somewhere that you can get the oil pressure up on the inst display somehow as the pressure seems to be dropping as the oil gets hotter and thinner
fish4tea
well update time, have changed the filter for the hell of it, but noticed that there was oil in the pressure sensor connector so gave it a clean and all seems well at the moment so will get a new sensor on monday,lets hope that's all it was, as going to be looking at the dash every 5 seconds now.
could be the sensor has let oil into the mechanism giving false readings.

would still be interested in finding out how to get all the engine readings on the trip display if anyone can point me in the right direction,cheers


Full Colour Version: Failing Oil Pressure??
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615