Help - Search - Members - Calendar
Full Version: Starting Problems With A Ford Galaxy 1.9Tdi
Ford Owners Club - Ford Forums > Ford Models > Ford Galaxy Club
Sue3008
Hi,

I wonder if anyone can help me I have a galaxy 1.9tdi 1997. It runs fine but have a problem starting it it is almost like I have to wind it up.

We have changed 2 relays 109 and 102 (I think that was the numbers my husband said he had changed), checked all fuses, have also had new glow plugs and glow plug sensor. We have had the power checked and there is no power going to the glow plugs but there is power going to the relays.

Has anyone got any suggestions as to what it could be? We are all out of ideas and don't want to change fuel pump as it is a costly job and knowing our luck won't solve the problem.

Thanks Sue
mintalkin
i can not remember on the galaxy if the plugs only work below a certain temp,the power to the relay is controlled by the ecu,you could have a problem with the temp sender unit giving the ecu false signals so the glowplugs are not required,you could do with a live data scan to see if the temp sender is working correctley. it could also be nothing to do with the plugs and have some other reason why its difficult to start.
Sue3008
my husband said he had changed the temp sensor. he has also had two Diagnostic checks run both found nothing
mintalkin
i know this might be a silly question but is the battery and alternator up to standard?
Sue3008
Not a silly question sometimes the obvious can be missed unfortunately not this time. Both the battery and alternator are fine.

Can you think of anything else as we are really at a loss.

Thanks
Sue


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615