Help - Search - Members - Calendar
Full Version: Help Turbo Boost Issues 2.0 Tdci Duratorq 130 Euro3
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
tdci stevie
Hi just thought i would start a new thread with added pictures of my problem.
When i floor it the rev needle jumps but the car doesnt, if i slowy apply throttle it has plenty of power is do a ton, its the moment a give it a little the car doent respond straihht away.
I had to change the big rubber inlet pipe that goes from intercooler to bottom of EGR a while back as loss of power and a hissing noise, so changed that and thought everything would be merry, but not has got rid of hissing noise and slightly improved performance, but still have this boost problem.
Have checked the little solenoid vac and pipe (pic 1) for splits and is fine, also getting vaccum from it (when idling) everthing seems to be fine there, chased the pipe to actuator on top of turbo and still no splits (pic 2).
I took off the vaccum pipe that goes from vac solenoid actuator and drove it to see what happens and it drives a lot worse....if this test helps
Had diagnostic machine put on and there are no stored or pending codes....

Any ideas or help in the right direction would be great....
tdci stevie
A diagram of the turbo and all associated hoses/vac pipes would be great, haynes manual are sh*t for things like that...
And if it was the turbo knackered why when i took vac pipe off acuator it made it a hell of alot worse...? :huh:
tdci stevie
Took vac pipe off from solenoid valve and sucked on it to make sure the actuator arm moves... and it does it all so holds until i release suction....
Please any help on this problem most appriciated starting to do my nuut in....


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.