Help - Search - Members - Calendar
Full Version: Lack of "GO" from my 1.8TD Endura DE
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
mondy man
Hi Guys, I have just bought a rather knackered Mondeo TD 1997 P Reg Endura DE Engined Hatch.
I have noticed the acceleration is very flat. The revs rise as they should but I am getting no percievable turbo boost and the progress to 5th gear range is very pedestrian, the turbo is or seems to be sucking and blowing where it should and the revs rise as I would expect but with no noticeable speed increase (on a par with a none turbo escort diesel I recently sold), I am not however hearing any "Whistle" from the turbo. I have been told that you dont get whistle on Mondy's anyway and that the turbo is working and it could be the MAF sensor, could this be correct?
Cheers
Dave
mintalkin
check for any split pipes also could be egr valve require a clean,you could try cleaning the maf but be carefull not to damage it
mondy man
[quote name='mintalkin' post='4209' date='Sep 15 2008, 08:43 PM']check for any split pipes also could be egr valve require a clean,you could try cleaning the maf but be carefull not to damage it[/quote]
CHEERS FOR THAT, WHAT IS AN EGR VALVE AND WHERE IS IT LOCATED?
DAVE
mintalkin
this will help but on your car it should be at the rear of the engine

[url="http://www.fordmondeo.org/forum/showtopic.php?tid/781083/"]http://www.fordmondeo.org/forum/showtopic.php?tid/781083/[/url]

also check the fuel filter
mondy man
[quote name='mintalkin' post='4240' date='Sep 16 2008, 09:35 AM']this will help but on your car it should be at the rear of the engine

[url="http://www.fordmondeo.org/forum/showtopic.php?tid/781083/"]http://www.fordmondeo.org/forum/showtopic.php?tid/781083/[/url]

also check the fuel filter[/quote]

Thanks for that but what does EGR stand for in case I have to go "Scrappy Bashing" again?
Dave
Rikos
Exhaust Gas Recirculation valve mate
mondy man
[quote name='Rikos' post='4314' date='Sep 17 2008, 09:49 AM']Exhaust Gas Recirculation valve mate[/quote]

Thanks for that, will keep you posted but I am disabled so will have to wait for a dry warmish day before I can look at it.
Cheers Guys
Dave
ghiax130
[quote name='mondy man'
ghiax130
[quote name='mondy man' post='4205' date='Sep 15 2008, 07:53 PM']Hi Guys, I have just bought a rather knackered Mondeo TD 1997 P Reg Endura DE Engined Hatch.
I have noticed the acceleration is very flat. The revs rise as they should but I am getting no percievable turbo boost and the progress to 5th gear range is very pedestrian, the turbo is or seems to be sucking and blowing where it should and the revs rise as I would expect but with no noticeable speed increase (on a par with a none turbo escort diesel I recently sold), I am not however hearing any "Whistle" from the turbo. I have been told that you dont get whistle on Mondy's anyway and that the turbo is working and it could be the MAF sensor, could this be correct?
Cheers
Dave[/quote]

have a look at your inlet manifold on the top of it there is a round diafram with a breather pipe on it check for oil leaks i had a diesel it was doing the same as yours and that was the problem from ford they are about 150 +vat so scrappy would be best


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.