Help - Search - Members - Calendar
Full Version: Galaxy Starting Problems
Ford Owners Club - Ford Forums > Ford Models > Ford Galaxy Club
pdsh1
Hi all, long suffering Galaxy owner here! This could be pretty straight forward to a learned mech, or a nightmare, so here goes. The glow plug light started to stay on when driving recently. Had the same prob before, general warning light as the brake switch was u/s. Replaced and all ok. Car has run for a couple of weeks since fine. Just been out today, left the car for 11/2 hours, central locking opened car via key, on attempting to start, clicking noise from the on board fuse/relay box, no engine turn over at all? Played with a few fuses, still no joy. Green Flag came out, suggested starter motor jammed and drained battery. He put a boost unit on, still no cranking. He added a further boost unit, car turned over and fired.
Drove home no problem. Turned off ignition and left for a while. Opened car with key, central locking did not operate. tried to start, same again, no crank, flashing symbols on dash. Clicking stops when brake pedal depressed, still will not crank though? Battery is recently new, I feel that is not the prob. Seems an electronic issue, even if starter is a bit iffy?
Any advise would be greatly appreciated!!
tommy.h
Hi
could be battery or alternator.
battery without engine running should be approx 12.5 volts.dropping to about 8 volts while cranking
with engine running approx 13.8 volts charging off alternator.
does sound like an alternator problem though.
as new battery would run the car for so long before discharging.

tom


Full Colour Version: Galaxy Starting Problems
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615