Help - Search - Members - Calendar
Full Version: No hot air coming from heater
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
mondy man
Hi guys meant to add this one on to the previous question about the lack of power.
I am not getting any hot air out of the heater, there is the right amount of water in the header tank, the blower works correctly at all speeds, it just doesn't get hot, and the hot/cold selector nob does not turn all the way to cold or right round to hot, any ideas?
Cheers
Dave
mintalkin
could be the switch panel playing up try some wd40 on it
mondy man
[quote name='mintalkin' post='4241' date='Sep 16 2008, 09:43 AM']could be the switch panel playing up try some wd40 on it[/quote]
Thanks again
Rikos
Cant beat a bit of wd40 :lol:

Any joy mate?
mondy man
[quote name='Rikos' post='4315' date='Sep 17 2008, 09:49 AM']Cant beat a bit of wd40 :lol:

Any joy mate?[/quote]

No, I had the heater panel off and there is a wierd cog that turns at an angle to the cable end and the wire that pushes through the bulk head was bent, so I bent it straight and it made no difference. I take it the heater matrix is under the windscreen scuttle and will have to be stripped to gain access to the other end of the wire, to see why the heater isnt going hot.
Dave
mintalkin
could be a seized heater controlle valve common on a lot of fords


Full Colour Version: No hot air coming from heater
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615