Help - Search - Members - Calendar
Full Version: Howling Noises
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
rbeilby
Ford Mondeo 2.0 TDCi 56 plate. Quite a howling noise when driving at 50+ m.p.h. It is similar to the transmission whines that older vehicles used to make. Salesman said it was a "feature" of Mondeo estates.

Now also getting another howling noise from OSF area when making sharp left-hand turn. Only noticeable at normal road speeds, not when very slow or stationary. So I do not think it is the assisted steering pump. It does not seem to be dependent upon the road surface either.

Any ideas appreciated.

Regards,

R. Beilby.
mintalkin
it could be a worn wheel bearing.
Kayfour
[quote name='mintalkin' date='13 September 2010 - 02:39 PM' timestamp='1284384542' post='97052']
it could be a worn wheel bearing.
[/quote]
I remember experiencing the same whining noise from the O/S front, which did actually prove to be the power steering pump. The other tell-tale sign was the appearance of froth in the pump reservoir !
rbeilby
[quote name='Kayfour' date='13 September 2010 - 02:01 PM' timestamp='1284385914' post='97059']
I remember experiencing the same whining noise from the O/S front, which did actually prove to be the power steering pump. The other tell-tale sign was the appearance of froth in the pump reservoir !
[/quote]

Thanks for the reply and information. I will check the reservoir.
rbeilby
[quote name='mintalkin' date='13 September 2010 - 01:39 PM' timestamp='1284384542' post='97052']
it could be a worn wheel bearing.
[/quote]

Thank you for your reply. I had that horrible feeling too! I will check the steering pump out first though.


Full Colour Version: Howling Noises
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615