Help - Search - Members - Calendar
Full Version: Problems, Problems, Problems...
Ford Owners Club - Ford Forums > Ford Models > Ford S-Max Club
SteveBailey
Hi I'm new to this but I see everyone else is used to problems with their S-Max!

I've just got a '09 plate S-Max Titanium 2.2TDCi and after a few days the phone unit failed. Not a big problem, just inconvienient...

The next day the sat nav crashed and I've now lost the CD, Radio and the climate control! The whole system appears to be repeatedly rebooting every three seconds and then keeps going dead.

Now I'm really a tolerant person but driving 1000 miles a week and having to wait until next week before my dealer can look at it I'm seriously not happy!!!

Has anyone else experienced this type of failure?

At least it's under warrenty!!!
CluelessMum
It's such a shame isn't it - I've got a 2007 S-Max and although it's great to drive, the build quality really doesn't shape up to the VW's I've had previously. I've had to have a new boot latch (man at garage told me it was my fault because "new mums always slam the boot too hard..." and so wouldn't claim on the warranty) and last week, spent 192 on resolving the bonnet cable problem (which stops the bonnet from closing, resulting in a bikechain and padlock repair job) that many seem to have suffered. The handbrake's fallen to pieces and the front parking sensors are useless! VW next time I think (at least I don't have to do 1,000 miles a week - nightmare to have an unreliable car)!


Full Colour Version: Problems, Problems, Problems...
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615