Help - Search - Members - Calendar
Full Version: Escort 1.6 Brake / Hand-Brake Issue
Ford Owners Club - Ford Forums > Ford Models > Ford Escort Club
terry2010
[b][size="2"][font="Tahoma"]Hello i drive a Escort 1.6 zetec. Basically my hand-brake goes up quite a few clicks and doesn't seem to hold very well on steep hills, has to be applied very high. I have checked my rear drums and pads. My drums are worn but not to the point where they need replacing but i did fit new pads.
I also checked the hand-brake cable which i cannot adjust any further as it is already on the tightest setting. It sounds to me that the hand-brake cable is stretched.. so dont want to fork out for drums if they dont need changing.. but would appreciate any advice. Thank-you[/font][/size][/b] :)
lublin
[quote name='terry2010' timestamp='1286923698' post='100785']
[b][size="2"][font="Tahoma"]Hello i drive a Escort 1.6 zetec. Basically my hand-brake goes up quite a few clicks and doesn't seem to hold very well on steep hills, has to be applied very high. I have checked my rear drums and pads. My drums are worn but not to the point where they need replacing but i did fit new pads.
I also checked the hand-brake cable which i cannot adjust any further as it is already on the tightest setting. It sounds to me that the hand-brake cable is stretched.. so dont want to fork out for drums if they dont need changing.. but would appreciate any advice. Thank-you[/font][/size][/b] :)
[/quote]
Try pressing really hard on the brake pedal, with the engine running, and pumping the handbrake up and down. This worked on my Escort when I first bought it. Also, the auto adjusters could be stuck.
terry2010
Thanks mate but that didn't make any difference. Will be replacing the hand-brake in the next week or so, will let you know if that solves it.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615