Help - Search - Members - Calendar
Full Version: Mondeo 2.0 Tdci, Overheating Or Not
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
garyjetbike
I have a 2.0 TDCi 130bhp Mondeo, 2004. Engine seems to be cooling but doesnt circulate water,hence bottom part of radiator is cold, top pipe is warm. Have changed water pump and thermostat, blowing warm in the car, but not hot. Temp gauge doesnt read until doing approx 80mph on motorway, then temp gauge drops when slow down. Does not move on tick over. Header tank stays cold. Anybody got any suggestions please?
mintalkin
it could be the second thermostat playing up.(oil cooler)
mikehaggis
[quote name='garyjetbike' timestamp='1291241306' post='105572']
I have a 2.0 TDCi 130bhp Mondeo, 2004. Engine seems to be cooling but doesnt circulate water,hence bottom part of radiator is cold, top pipe is warm. Have changed water pump and thermostat, blowing warm in the car, but not hot. Temp gauge doesnt read until doing approx 80mph on motorway, then temp gauge drops when slow down. Does not move on tick over. Header tank stays cold. Anybody got any suggestions please?
[/quote]
Have you checked that the radiator is circulating correctly? You will have to backflush it to be sure. Strange that it does not seem to be overheating which is what you would normally expect with a blocked rad. Try taking the themostat out altogether and see if the water starts to circulate properly as the thermostat could be jammed even if it is new. Make sure as well that the water pump is actually operating as well. Hope this helps
regards
Mike


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.