Help - Search - Members - Calendar
Full Version: Newbie
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > New Member Introductions
getaway_driver2003
Hi Guys,

I'm new to the forum having just bought myself a Ford Mondeo 53 plate 2ltr Zetec. It's silver (or so they would have me believe) with around 84k on the clock. Lovely car to drive... However... The mileage I'm getting is pretty bad. Let me set the scene... I drive on rubbish traffic on back roads for 6 miles and I'm getting around 24mpg... Also the performance isn't quite as good as I expected. Now that might be down the the fact my last car was a 2.5 v6 twin turbo but even so it feels a little sluggish... And I used to get about 21mgp from that... It hardly seems worth the trade right now.

So I apprecaite with the traffic and the cold it's not going to be great mpg but i was expecting a little better than that... Just had the car a major service so shouldn't be filters (reset the trip computer afterwards too). Anyone a suggestion as to why... And no, I'm not hitting the gas hard trying to make up for the loss of power... I have two kids in the back to look after!
jmurray01
Welcome to the Ford-Owners-Club! B)
Gazjs
Welcome to the forums :)
Escort 1980
Hi All, I'm Gavin from South Africa, I am currently restoring a 1980 Ford Escort 1600 GL to it's former glory, I will post pic's of progress.


Full Colour Version: Newbie
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615