Help - Search - Members - Calendar
Full Version: Focus 05 Wipers Not Working
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
luckyman
Hi folks can anyone help my 05 focus front wipers have stopped working my wife left them on ,i went out to start it up but they were frozen when i started and defrosted they would not work,the water pump wprks and also the rear wipers,when i move the arm for the front wipers i hear a click coming from the fuse board below the glove compartment i dont have a manual but think fuse number 55 is the wipers i have changed it but they still dont work any one have a diagram of the fuse board as theres no diagram on it any help much appreciated
H3lly
There might be damage to the wiper linkages or the wiper motor. If you tried to operate them whilst they where frozen it can cause them to burn out. There is power going to them if you can hear the relay clicking.
tommy.h
Hi Luckyman

this any good? attached.
bearing in mind this is for 1998 - 2005 model.

tom
luckyman
Thank you both for the excellent advise it is now sorted turned out to be fuse number 50 on the board below the glove box

THANX
stef123
the mk2 focus seem to have a thing for fuses? my brothers mk2 has went through about 3 or 4 as far as i know, its also had some of the wiring replaced due to a fault. what rating is the fuse?
luckyman
hi the fuse is a 20 amp but ive stuck a 30 amp in and it works so i'll leave it until/if it blows again ha ha ha


Full Colour Version: Focus 05 Wipers Not Working
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615