Help - Search - Members - Calendar
Full Version: Intermittant Engine Electrics Problem
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Wdave
Hi,

I have a 1.8 Ztetc petrol engine Ford Mondeo Mk3 (2002). It recently had a recon engine fitted and the engine appeared to be fine initialy, but after three days of driving it has developed a fault in that the engine cuts out temporarily for 2 or three seconds and then drives ok again, until the next time. The battery warning light and the engine management light came on whilst the engine cut out.

I've taken it to another garage and when they came to start it, it would't start at all. They wriggled the engine wiring loom a bit and it fired up ok. The garage are saying that it would be easier to fit another wiring loom obtained from a breakers, rather than trying to diagnose the specific problem. I assume the problem is a loose connection or broken wire.

Can you tell me, are they correct in this assumption and how much labour (and cost) would it normally take to fit a new wiring loom?

I don't want to take it back to the garage that fitted the recon engine as they held onto the car for five weeks to do the job, and there's no knowing how long they would keep it this time.

Thanks.
tommy.h
Hi Dave

take a look at attached.
see if it helps.

tom
Wdave
Hi Tom,

Thanks for this. I'll have a look to see if it's a bad earth connection.

Regards- Dave


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615