Help - Search - Members - Calendar
Full Version: Mondeo Almost Stalls?????
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
Mark1976
Hi
I am new to forum and thought someone might be able to help me. I have a 2001 'Y' plate Mondeo hatchback done 89000 miles in very good condition and very well maintained. I have owned it for a couple of days now and very happy with it apart from one small problem. Since yesterday it looks as if it will stall when i come to a junction as the revs drop very low but then gains revs to compensate, so as of yet it hasnt stalled but very close. When it drops this low the battery light also comes on then goes off when revs have gained. I have fitted a new battery as the indicator was red and also failed the multimeter test. I also am giving it a service at the weekend. Is it the cold? is it the Alternator?
Thanks
Mark
tommy.h
Hi Mark

is this petrol or diesel and which engine.

tom
Mark1976
Hi
Its petrol, 1.8 i zetec.
Mark
mintalkin
check all the small vacume pipes for splits or damage,a faulty pipe would give your symptoms.
tommy.h
Hi Mark

may be worth checking IDLE CONTROL VALVE & giving it a clean this can also cause the problem you are getting.

tom
Mark1976
Hi Tom
Thanks for the info, I will check all.
Mark


Full Colour Version: Mondeo Almost Stalls?????
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615