Help - Search - Members - Calendar
Full Version: Mondeo Mk3 1800 Petrol Judder
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
mike g
Hi All,

I am new hear and have been told good things about the forum, i have a Mk 3 2003 Mondeo 1800 petrol HE Duratec, i bought it, drove it home and when i got home checked everything such as oil, water coolant etc and the oil level was low, very low, the car drove absolutely fine.

I did an oil change, filter and changed the plugs, the plugs were a little bit black but nothing unusual, now when i drive the car there is a slight judder when the car is at low revs, also on the motorway it doesnt pick up as well as it was and sometimes judders at higher speed, it is as though the car is running out of petrol.

I am running it low on fuel and will fill it up today and stick some injector cleaner in, i will also check the air filter as i dint change that, i have been told to get some fuel injection air intake cleaner and spray that to see if it works.

Before i changed the oil the engine warning light came on so after the oil change i disconnected the battery and left off for a few hours, now it is back on this judder happens and wierdly the temporature sensor shows wierd readings such as 36 F!! The little star which shows it is icey still comes on in the morn but the temp is wild - This is not the car temp just the outside one - could the sensor have been knocked or moved while i was working on the car? i have no idea where it could be?

Sorry for my first post to be like this, and thank you in advance for any help you can give me,

Thank you

Mike
fishpond 47
[quote name='mike g' timestamp='1292230616' post='106599']
Hi All,

I am new hear and have been told good things about the forum, i have a Mk 3 2003 Mondeo 1800 petrol HE Duratec, i bought it, drove it home and when i got home checked everything such as oil, water coolant etc and the oil level was low, very low, the car drove absolutely fine.

I did an oil change, filter and changed the plugs, the plugs were a little bit black but nothing unusual, now when i drive the car there is a slight judder when the car is at low revs, also on the motorway [b]it doesnt pick up as well as it was and sometimes judders at higher speed[/b], it is as though the car is running out of petrol.

I am running it low on fuel and will fill it up today and stick some injector cleaner in, i will also check the air filter as i dint change that, i have been told to get some fuel injection air intake cleaner and spray that to see if it works.

Before i changed the oil the engine warning light came on so after the oil change i disconnected the battery and left off for a few hours, now it is back on this judder happens and wierdly the temporature sensor shows wierd [u]readings such as 36 F!! The little star which shows it is icey still comes on in the morn but the temp is wild - This is not the car temp just the outside one [/u]- could the sensor have been knocked or moved while i was working on the car? i have no idea where it could be?

Sorry for my first post to be like this, and thank you in advance for any help you can give me,

Thank you

Mike
[/quote]

double check you've not put a plug lead back on the wrong plug, better still fit a new set of leads. If I remember correctly by resetting the ecu (not sure if you've done it the correct way on a mondeo), you have to let it learn the engines behavuor ie it's tick over speed and at a steady rev speed.

[u]Press the button on your temp gauge and it will change it back to Celsious[/u], I'm guessing the orange light will show at 36F which is about 3 or 4 Celc
mike g
Thank you for your reply, i made sure the plugs were put in the riht hole, i did them one at a time but i agree the leads could do with a change, it does feel wierd like the fuel is not right and it is using a lot of fuel, i have put 40 in it and have done about 120 miles at the min, i bet i have got max another 100 miles out of it!

What is the right way of resetting the ECU as te idle speed is just below 1000 and then goes back to just above 1000 so when you slow down it is al thought the car is goin to stall, it never does it just revs itself a little

Temp guage - That is what it is, sory for being thick, how do i press the button and change it, (i feel thick now!)

Cheers again
Mike
mike g
temp guage sorted thank you :-)
air intake cleaner in, engine ecu reset and then i set the revs, will drive tomorrow and see what it is like, how posible is it that the leads will fix the judder, is there a way of testing? or engine coil pack? i know it is only 40 for the 2 bits but i am not keeping it so i dont want to spend an more money on it?? cheers everyone
mike g
Car has been driven about 200 miles, every now and again there is still a small judder but this is when i am in a high gear at low revs.

more fuel and redex in, and i have sprayed 30 seconds of air intake fuel injection cleaner and the judder has stopped.

If it comes back but goes after i clean the injectors could the coil pack and HT leads be at fault?

I have put the car on e bay now and am looking at a newer mondeo so want to sell it as honestly as possible.

Any ideas

Thank you


Full Colour Version: Mondeo Mk3 1800 Petrol Judder
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.