Help - Search - Members - Calendar
Full Version: Engine Warning Light On!! Help Please.
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
dp1987
i have a problem again lol. Just got rid of one focus that had problems and now have a 2002 1.6 chic special edition.
Ive had it a few days and the engine warning light has come on. Ive still used it the last 2 days its been on but its jolting/ jerking when accelrating and seems to struggle getting power when taking off in 1st. Ive spoke to someone and he thinks it might be the spark plugs or coil pack need doing and thinks it might have misfired. But ive heard that it could just be damp in the spark plugs?? how do i sort that out?
could it be anything else?? i test drove it for about 10 minutes 3 days before buying and it was fine but 2 days into owning it this has happened. It passed its mot with no advises 2 weeks ago at a proper ford garage so it should be ok shouldnt it? :(
thanks
H3lly
The water jets are known to leak and pool water on the tops of the spark plugs. I think ford are aware of this and have modified tubing for them.
jmurray01
Replace the HT leads and spark plugs, see if that helps. If it does, then investigate how the old plugs stopped working in the first place.
dp1987
should i not get the spark plugs checked for damp first at a garage?? would they need to run a test aswell to see why the engine warning light is on?
thanks
mintalkin
i would get the fault codes read first before spending money on anything that 'might' cure the problem, it sounds like a plug, lead or a coil pack misfire but you could replace these and still have the eml on because its another problem,so start with the fault codes.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615