Help - Search - Members - Calendar
Full Version: Smelly
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Shahed Khan
Hi Guys need your help once again lol basically its been snowing here really bad in south, as i was driving my car and my heater was on full blast and it was all working fine and that, then suddenly strange smell started to come out from Air vent at first i thought it mite be the rubber from the tyres but today i drove again put the heater on started to smell again, dont know what could it be, anyone had this problem? opened the bunnet cant seem to find anything leaking or lose

Thanks in advance
cressws1
Change pollen filter and Air filter. If either of these get damp at all they stink to high heaven.
Shahed Khan
Thanks Buddy, any idea the cost?
r0b3r7
check http://www.eurocarparts.com, enter your reg and it'll show you all parts available for your car. the most expensive one for my car (2004 1.6) is 13.81 cheapest is 7.17

Hope this helps
Shahed Khan
Legend Man, Thanks
mikey-james
i had this problem a while ago....i was my clutch haha..bad times... :huh:
Vinny2010
[quote name='Shahed Khan' timestamp='1292788594' post='107216']
Hi Guys need your help once again lol basically its been snowing here really bad in south, as i was driving my car and my heater was on full blast and it was all working fine and that, then suddenly strange smell started to come out from Air vent at first i thought it mite be the rubber from the tyres but today i drove again put the heater on started to smell again, dont know what could it be, anyone had this problem? opened the bunnet cant seem to find anything leaking or lose

Thanks in advance
[/quote]

I have this problem at the minute, did you find out what it was, ford can't seem to fault find....


Full Colour Version: Smelly
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615