Help - Search - Members - Calendar
Full Version: 1.8Tdci Burning Smell Inside Cabin
Ford Owners Club - Ford Forums > Ford Models > Ford Mondeo Club
car67
HI all,

I have a second hand 1.8tdci mondeo with approx 38k on the clock, it's an 07 plate. I've had it for 4 weeks but over the last week or so there has been a really sour pungent burning smell when I start the engine, almost like burning oil inside the passenger area. I think it's only when the heater is on to heat - I am still testing out the theory that when I put it to cold the smell disappears (it's hard to tell). There is no visible smoke inside or outside the car. I have a 10 month old baby and I really don't like the fact that I am breathing it in, never mind baby too. I have tried not to use the car because of this problem :(

Since it's been cold and snowy I have had the pleasure of standing outside while the car heats up, but I can smell the smell outside too. Might be the exhaust? The fumes do not look dirty or blue. I had a quick look at the oil, it's dark and the level was OK. I looked under the bonnet for any leaks, but I couldn't see anything. The car was serviced and MOT'd last month and everything was OK.

I should point out I am a female (be nice to me please), and was hoping that anyone could give me some pointers on what this might be? I do have the car booked into a local garage (not a dealer) for a check. Am worried I have a major issue here....
Thanks
mintalkin
when the car was serviced did they change the fuel filter?,it sounds like there is a leak of exhaust fumes, diesel(fuel filter injectors ect) or oil, a good inspection around the engine should soon find out where the leak is and what is causing the smell
car67
Hi Mintalkin, thanks for that. I took the car up this morning, whereby it was really strong the odour/fumes I had to drive with the window open and no heater on. The garage have said they cannot see any leaks in the engine compartment and that if it were exhaust fumes it would be there constantly and not disappear. The mechanic took the car out with him and gave it a good run, but couldn't find anything wrong/smell etc. He left it to go cold, tried again and still nothing. He took me out in it later on and there was no odd fumes/smells either. Strange. Am wondering if this severely cold weather is somehow causing this?
I have to try again tomorrow morning and see what happens, and to also run the heater with the re-circulate instead of fresh air intake and see if this makes a difference.....It is really annoying. Will report my findings.
SNAKEBITE
Silly suggestion but is it the heater resistor?

I have a Mk2 Mondeo that developed a funny smell just before the resistor went south.

When it goes you will only be able to use the heater fan on full, none of the lower settings will work.
(Don't worry though it was only 13 to get a new one, plus 12 if you need a new harness link).

The smell was pungent and "plasticy".


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615