Hi there I posted this original topic below, in the wrong forum, so hopefully you Mondeo guys could help me out.Further to the topic below I slid into the back of a Lorry in the snow this morning and now need to purchase a new bonnet. Any ideas were I can get a cheap second hand bonnet and are they easy to fit?

Hi there, I am new to this forum but not new to Mondeos. I had a 52 plate 130 tdci ghia X auto estate between 2004 to 2007, absolutely fantastic car no problems ever,went to 210,000 miles before it was finally written off by a lorry on M6. Anyhow I was so impressed I have just bought another.Its a 51 plate mondeo ghia 2.0 tddi estate, strangely enough the same colour, pale metallic blue.I have bought it of a neighbour, it has 120,000 on clock but drives like new and is in imaculate condition with every thing working and has been serviced regularly. The tddi engine is noticebly different to the tdci on my first and I have a number of queries I wanted to put to all you experts out there to see if I have any up and coming problems or if its just a typical trait of these engines.

1.When driving, more so when its from cold, the engine seems to rev for a second then die back down to normal. When I say rev the engine itself doesnt actually go any faster, the revs stay the same and the clutch isn't slipping, its more of a revving noise. Is there an issue with the turbo? The car does seem to accelerate fast almost as if it is being pushed along when driving and seems noticeably more responsive than the tdci engine. Definately no turbo lag here. Is this a usual trait of these engines. There is no smoke at all coming out of the exhaust not even under heavy acceleration.

2.When sitting in the car with the engine warm and ticking over smoothly every now and again there is a slight hesitation in the engine almost like a misfire, with a slight knocking bumping noise when it happens, its almost like it moves the car. This doesn't always happen and is only occassional. Is this common due to its age or is there an up and coming issue.

3.The steering seems a little light sometimes. The previous owner had a new hydriloic steering pump fitted last year. When your manouvering from a standing start it seems that the steering is a little heavy then all of a sudden the power steering kicks in. Is this lag a common problem, and should it go over light when driving at speed? I wouldnt say its a majorly noticeably issue just every now and then it feels a little disconcerting when driving.All my tyre pressures are correct.

4. The previous owner had new back springs fitted, but the back end of the car seems a little bit bouncy going over bumps. Would this be cheap and poorley fitted components? I cant ever remember my previous mondeo feeling like that although it did have a different wheel set up with 17" rims instead of the 16"s I now have.

Thanks in advance to any of you guys who can answer any of my queries.
Rob