Help - Search - Members - Calendar
Full Version: Streetka Losing Power In Wet
Ford Owners Club - Ford Forums > Welcome to Ford Owners Club > General Ford Related Discussions
FordSTKA
Hi everyone,
I am having a bit of a problem with my Streetka. I have a light that comes on and I have been told that it is the engine management light. I am having problems with my car because whern I am driviing along, I suddenly lose power and just crawl along really slowly even if I put my foot down; then it might judder back to life for a few seconds! I almosyt stopped completely today. I managed to get back home and later tried the car again. The light came on after about five minutes of driving and I had to pull over as I was just juddering slowly along. Any clues to what it might be and more importantly what it might cost to get it sorted!!!
Thanks
btmaldon
Could just be your HT Leads breaking down, coil pack may need replacing or the crankshaft sensor needs either replacing or there is damp on the contacts. Could also be damp on the fuel injector contacts although I doubt it. All should be relevantly cheap and easy to fix. I would start by changing the coil pack and checking the leads as well as checking the connection to the crankshaft sensor. If coil pack is not to blame, it is likely to be the leads. If the plugs havent been changed for a while it may be worth doing those as well. Crankshaft sensor is probably the last thing to change.

Have you got breakdown cover? You could call them out and get a free diagnostic check.
AliciaBeckman
I think you should change the gas filter. Welcome to the forum. :)
mikehaggis
[quote name='FordSTKA' timestamp='1294517865' post='109091']
Hi everyone,
I am having a bit of a problem with my Streetka. I have a light that comes on and I have been told that it is the engine management light. I am having problems with my car because whern I am driviing along, I suddenly lose power and just crawl along really slowly even if I put my foot down; then it might judder back to life for a few seconds! I almosyt stopped completely today. I managed to get back home and later tried the car again. The light came on after about five minutes of driving and I had to pull over as I was just juddering slowly along. Any clues to what it might be and more importantly what it might cost to get it sorted!!!
Thanks
[/quote]
Hi I had a similar problem with a sierra which was due to the coil being located low on the inner front wing so if you went through a deep puddle the car would cut out completely until it dried out! also i recently had a 2006 Focus 1.8 TDci which had similar problems to yours with the exception that it died completely and would not restart. After the third attempt by Ford to fix the problem I ended up giving the car back because when it cut out there was no warning and i was concerned about the safety angle because i travel on the motorway Alot with my Kids in the car.Imagine the scenario of overtaking slower moving traffic and having the car die completely in the middle lane!!
I do not think you have this problem though as you have been able to limp home, so i think it is due to water getting onto the electrics some where. The slow running and juddering is due to the engine managements limp home mode which kicks in when there is a problem with the system. This is what SHOULD have happened on the Focus but in my case it just cut out alltogether.


Full Colour Version: Streetka Losing Power In Wet
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615