Help - Search - Members - Calendar
Full Version: FAN BLOWERS NOT WORKING
Ford Owners Club - Ford Forums > General Forums > Maintenance / Servicing / MOT Discussions
slingmaker
Hi guys

The blowers in my focus only work on level 4 , ive been intouch with a local mechanic and he said he can sort it for 50 . He said i need a resistor unit . If so are these easy to fit ? as i would do it myself . Any ideas on what else it could be ?

Cheers
mintalkin
its most likly the resistor pack which is located behind the glovebox and held in place by an 8mm bolt, but it could also be the dash switch. 9 out of 10 times its the resistor pack
slingmaker
[quote name='mintalkin' post='6130' date='Oct 10 2008, 01:51 PM']its most likly the resistor pack which is located behind the glovebox and held in place by an 8mm bolt, but it could also be the dash switch. 9 out of 10 times its the resistor pack[/quote]

Where can i pick one of these up and are they easy to fit ??? a local mechanic said hed do it for 50 supplied and fitted but i cant really affoRd to pay that .

Cheers for your help
mintalkin
give these guys a ring and find the price of the resistor pack

[url="http://www.fordpartsuk.com/"]http://www.fordpartsuk.com/[/url]
Mattie
Hello mate, i had the exact same problem with my 96 fiesta, what had caused it was the multiplug behind the glovebox had burnt out, so i cut the plug off and attached spades to the end of the wiring and connected them manually and now it works like a dream and it took me bout 10 minutes and cost me 7.99 for a big spade wiring kit but really all yu need is 4 fittings which will cost bout 50p hope this helps
Chris413
Is the resistor pack in the same place on a Ford Puma? I have already replaced the HCV and the speed switch and still no blower.
mintalkin
yes i think it is,if you puma was built before 10/1999 The problem may be caused by a poor electrical contact of the blower motor resistor multiplug. The high current passing through the resistor may be the cause of the melting multiplug. The solution is to fit a new blower motor resistor that has modified connectors that can withstand the high temperatures along with a new wiring loom to the resistor.
RichardE

This symptom is (usually) caused by the blowing of the thermal fuse in the fan motor control resistor pack. (The resistive power drop is a really cheap way for Ford to control the current, and hence the speed of the fan).The reason the fan works on setting 4 and not on the other 3 settings is that the full speed setting 4  bypasses the resistors and the thermal fuse.[Those with A/C would also find that the A/C doesn't work at all as it only works with fan speed settings 1-3.]

 

This resistor pack is quite awkward to get at as it is located behind the glove box and some ducting for the heated air. The reason it is there is that Ford use the airflow from the fan to cool the resistor pack (which can get pretty damned hot!). However, with some squirming around on your back, a long shaft Philips screwdriver and so on it can be removed and replaced by a "normal person". [The Focus Haynes manual has a small section detailing the heater blower removal and the location of the resistor pack]

 

In my case I had the A/C and the fan stop working on settings 1-3 a few years ago. The local garage replaced the resistor pack and everything was good again. A month or so later the new pack failed. Initially it was suspected that it was just a faulty pack so they fitted another free of charge. Again a few weeks later this second replacement failed. (This next bit may seem a bit dodgy!) The mechanic said that he had had this happen before on another customers car and that, in some frustration, they had soldered a wire across the thermal fuse to prevent it happening again and this had fixed their problem. With some concerns I gave him the go-ahead to do this and all seemed well until the winter, when the fan blower failed again. As the thermal fuse had been bypassed it didn't seem that this could still be the same issue but ... yes it was. The resistor pack had got so hot that the solder melted and the bypass wire fell off!!

 

Clearly we had some other issue  - and this is where the cheapness of Ford's design solution comes into play. In my case what was actually happening was that the fan was running slightly slower than expected particularly on setting 1. Some condensation from the A/C, or just incoming moisture, had slightly corroded the bearing for the fan motor so it wasn't turning as smoothly as it should. (In some cases I have heard of them squealing). As the airflow from the fan is used to cool the resistor pack eventually the pack gets too hot and blows the thermal fuse. This is most likely to happen on setting 1 since this has the least airflow and the highest power drop through the resistor pack. 

 

I removed the blower unit and cleaned and oiled the bearing, replaced the resistor pack (again) and it's still going well 6 years later.

 

 

 

sluffy2000
This has just happened on my 59 plate fiesta zetec. Is it in the same position (behind the glove box)? and is it easy to do yourself. Everything was working fine then I went on holiday for 3 weeks, came home, started it up and it only works on speed 4. Thanks
paddyboy
Hello I have a fiesta zetec z 02 plate mk5 and the blowers have stopped working on all settings ice tryd two new resistors and checked all fuses plus also tryd my control panel in another car and work please can someone give me some advice only thing I can think of is the blower where is this located on a zetec s mk5 thanks


Full Colour Version: FAN BLOWERS NOT WORKING
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.