Help - Search - Members - Calendar
Full Version: '57 Focus 1.8 Tdci Maf Sensor Fault
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Disco73
I hope someone can help.

Fault code showed intermittent fault with Mass Air Fow Sensor. Mechanic replaced the sensor, cleared the fault. The warning light has now came back on intermittently and is now showing the same fault code 1 day later.

Mechanic is going to check the wiring again but has said if it's not this it may need a new ECU.

Any advice/comments greatly appreciated.
mintalkin
do you know what fault code is being lifted from the car?
Disco73
I think it was 104.

Can check with mechanic tomorrow
Disco73
Fault code is PO104.

Mechanic cleared the fault again, no loose wires. Will have to see if it comes back on. I imagine it will as the code states its an intermittent fault
keith-focus
Disco73, intermittent faults are the worst. You have to reproduce the fault at the garage for anyone to look at it, which can be very difficult.

I have the same model as you and I had a similar problem. Mine started off with no increase in revs at start up and going into limp home mode above 3000RPM.

To cut a very long story short, the (first non-Ford garage) diagnostics showed MAF, so they changed that and it didn't fix it (found after I drove it home). They couldn't believe it so they changed it again for an original Ford part and that didn't fix it either. Each time they reset the ECU and revved the car the same fault appeared on their equipment. They gave up, so I had to take it to a Ford garage.

The Ford garage ran diagnostics that pointed towards MAF and throttle position sensor. They tested both and found both were working, so they tested the wiring and found an incorrect voltage at pin 3 of the MAF. They traced this back to pin 14 on the battery junction box, where they found a bad connection. They "repaired and made good the connector". 94 quid later my problem was fixed.

This may not be the same problem for you, but I have learnt not to take the results of the diagnostic equipment at face value. In my case there appeared to be something wrong with the MAF but it was actually a wrong voltage caused by something else.

I hope this help you, Keith
Kris.vr4

Guys is there any body can help me and write me down wiring to maf sensor?

[URL=http://s987.photobucket.com/user/jkrzysztof80/media/20130707_214930.jpg.html][/URL]



This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615