Help - Search - Members - Calendar
Full Version: No Throttle/revs On Focus Tdci,
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
mgbglasgow
Hi all,

just to let you know i had some issues with my W plate ford focus,

When i was driving, every 15 miles or so, the car would suddenly lose all power, not rev, but the engine was still running.

Checked the forums , and the suggested new throttle pedal assembly,

I changed that, and seemed better for a while, but was doing short journeys. Then it returned, RAC came out and noticed that 5 faultcodes where in memory. He cleared that then followed me to work (excellent service!), and no fault was found, but checked to see if car would start/rev, it didnt, and RAC chap checked codes, the 5 where back.

Checked circuit diagram, and the five all fed off on portion of the circuit diagram, so being an electronics engineer, decided to reseat the connectors on the ECU,

Result, 3 weeks of driving with no breakdowns whatsover. The ecu is at your feet on the right bulkhead, its footery to get at , but just break and make the conns again and refit to bulkhead. What i think was happening was as the car was heating up, the connections where opening up slightly, so short runs/ cold car meant no breakdown, M8/mway meant warm car + breakdown,

Before yoyu spend any cash, check the connection at the ecu, and while you are down there, take a 10mm socket and remove, remake the conns to the pedal assembly too.


Other tip is take off the intercoller and pipes and spray in boost cleaner, what a difference to the car, and keeps the EGR valve issue at bay for a while at least.

Steve in Glasgow
catch
Good tips,

and I'm sure somebody will be grareful for that info some day.

catch
taffg
good effort mate, thanks for some good solid advice. :)
APJ
good EGR tip mate, might have to try that cos mine is playing up!


Full Colour Version: No Throttle/revs On Focus Tdci,
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.

Warning: require_once(/var/www/applications/ipb/3.4.5/upload/sources/classes/class_email.php): failed to open stream: No such file or directory in /var/www/applications/ipb/3.4.5/upload/lofiversion/ipsclass.php on line 1615