Help - Search - Members - Calendar
Full Version: Very Puzzling Rear Light Situation?!
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
Eazy E
My mk1 Zetec has a very perculiar complaint. A few days ago as I was dropping a friend home, as I drove off he pointed out to me that one of my left rear light had gone out. Being the same bulb as the left brake light the left brake light too was not working. So as you do I drove off to by a bulb the next morning, I fitted it in a matter or minutes. I then turned the engine over flicked the lights and the [u]left rear light still would not light up, but the left brake light would. I've change the bulb 3 times and no joy brake light working but not the main rear. I tried the same bulb in the other side just to check I had the right one and it worked fine, both brake light and rear light.[/u]So the next day I took apart them back left boot cover and checked all the wiring which appears to the untrained eye fine, checked and no visible loose connections. I've checked the inside of the bulb holder and no issue again no corroding etc.

Anyway, the rear left light still won't light up and It's bugging me, apart from the fact it's harder to be seen without it on anyway I'm likely to get pulled if it gets spotted. I'm at a complete loss as to what is up with it. I heard the whole rear light system is on the same circuit so apparntly it can't be the fuse? That's the only thing I haven't tried. But I'm lost, has this happened to anyone or can anyone think of a solution. may just be a common sense issue so feel free to chip in. thank you.
H3lly
Replace the bulb holder. I had a similar problem with my stop lights recently, and that was the fix. Even though it looked ok, no corrosion etc.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.