Help - Search - Members - Calendar
Full Version: Sluggish Focus 1.8
Ford Owners Club - Ford Forums > Ford Models > Ford Focus Club
lbonniebell1
Hi, Please help!!!! I have a 2002 Ford Focus 1.8 Zetec with 97000 miles on the clock. It seems to feel really sluggish especially when going up hills. I have had it serviced including new plugs, air filter, new leads and a coil pack. It is not showing any engine management lights at all and my local garage says until it does this there is no point plugging it into the computer. Can anybody shed any light on this please?. Many thanks in advance.
H3lly
That response from the garage wasn't really helpful at all. The eml doesn't have to be on for there to be codes stored. Anyway, I'd be checking the vacuum hoses for air leaks, particularly the pcv hose in under the manifold. It could also be a maf issue. These are all things you can find yourself and the repairs are easy to do.
lbonniebell1
[quote name='H3lly' timestamp='1300046156' post='118338']
That response from the garage wasn't really helpful at all. The eml doesn't have to be on for there to be codes stored. Anyway, I'd be checking the vacuum hoses for air leaks, particularly the pcv hose in under the manifold. It could also be a maf issue. These are all things you can find yourself and the repairs are easy to do.
[/quote]

Thanks alot for your advice. Will hopefully get it sorted now.


Full Colour Version: Sluggish Focus 1.8
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.